Bug 989622 - Unable to build upstream spice-gtk against rhel6
Unable to build upstream spice-gtk against rhel6
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity high
: rc
: 6.6
Assigned To: Christophe Fergeau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 12:41 EDT by Swapna Krishnan
Modified: 2013-08-19 08:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-19 08:09:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Swapna Krishnan 2013-07-29 12:41:17 EDT
Description of problem:
I'm trying to clone from upstream repo git://anongit.freedesktop.org/spice/spice-gtk/ and build spice-gtk on RHEL 6.4 host. Unfortunately, I'm hitting failures while doing so. I have disabled introspection.

[root@hp-z800-01 virt]# 
[root@hp-z800-01 virt]# /mnt/tests/autotest/client/tmp/virt/src/spice_gtk/configure --with-gtk=2.0 --disable-gtk-doc --disable-introspection --prefix=/mnt/tests/autotest/client/tests/virt/qemu/install_root
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking build system type... x86_64-unknown-linux-gnu
...
checking for deflate in -lz... yes
checking for SMARTCARD... yes
checking for USBREDIR... no
checking for usb.ids... /usr/share/hwdata/usb.ids
checking for makecontext... yes
checking for swapcontext... yes
checking for getcontext... yes
/mnt/tests/autotest/client/tmp/virt/src/spice_gtk/configure: line 20315: syntax error near unexpected token `0.6.7'
/mnt/tests/autotest/client/tmp/virt/src/spice_gtk/configure: line 20315: `GOBJECT_INTROSPECTION_CHECK(0.6.7)'
[root@hp-z800-01 virt]#

Per conversation with Marc-Andre, filing this bug. Conversation below. 

---- Mensaje original -----
> Why is this?

Mostly because of autotools limitation, we require gobject-introspection macros (and perhaps other recent macros & functionnality). Although now that I think about it, we may found some workaround.. It's just that no one is doing development in RHEL6 environment, and the tarball is enough for RHEL build and releases.

Feel free to open a bug, it could be easy (or it could be hard and not worth it)

----- Mensaje original -----
> Hi,
> 
> I'm trying to clone from upstream repo
> git://anongit.freedesktop.org/spice/spice-gtk/ and build spice-gtk on RHEL
> 6.4 host. Unfortunately, I'm hitting failures while doing so. I have
> disabled introspection. So, I'm not quite sure why I'm seeing this failure.
> 
> Any help is appreciated.

To build on RHEL6, you need the released tarball, or you will have to run autogen.sh from a recent fedora, and then build the resulting tree in RHEL.


Version-Release number of selected component (if applicable):
upstream spice-gtk

How reproducible:
100%

Steps to Reproduce:
1. Clone spice-gtk from git://anongit.freedesktop.org/spice/spice-gtk/
2. Build using ./configure --with-gtk=2.0 --disable-gtk-doc --disable-introspection 
3. Fails
Comment 1 Marc-Andre Lureau 2013-08-19 08:09:20 EDT
the patch is upstream
http://cgit.freedesktop.org/spice/spice-gtk/commit/?id=d0a71934c12a748054fafd1ba9007d45071cc822

Since this is a git build issue, and not a RHEL release issue, closing

Note You need to log in before you can comment on or make changes to this bug.