Bug 989627 - nodes lib function decompress() strips more than .gz when filename ends in (g|z)
nodes lib function decompress() strips more than .gz when filename ends in (g|z)
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: nodes (Show other bugs)
2.2 Beta
Unspecified Unspecified
medium Severity medium
: ---
: 2.2.0
Assigned To: Jeff Ortel
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 12:47 EDT by Jeff Ortel
Modified: 2013-09-10 11:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 11:45:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Ortel 2013-07-29 12:47:42 EDT
The nodes lib function decompress() strips more than .gz when filename ends in (g|z).  Uses rstrip('.gz') which strips the specified characters in any order.  This mainly affects the unit tests which fail when generated file names (see: tempfile) end in (g|z) but could cause other issues.

Example: /tmp/tmpABCD/tmp123z 

when compressed is:

 /tmp/tmpABCD/tmp123z.gz 

but decompresses to:

 /tmp/tmpABCD/tmp123.  

Note trailing 'z' removed.
Comment 1 Jeff Ortel 2013-07-29 12:55:11 EDT
https://github.com/pulp/pulp/pull/546
Comment 2 Jeff Ortel 2013-08-01 23:42:19 EDT
build: 2.2.0-0.23.beta
Comment 3 Preethi Thomas 2013-08-09 11:20:41 EDT
moving to verified

<jortel> as for 989627 - 2 things:
<jortel> 1. we dont see this in production because the file names dont end in (g|z).  really just affected generated tempdir names in unit tests
<jortel> 2. in 2.3 this entire module goes away.
Comment 4 Preethi Thomas 2013-09-10 11:45:24 EDT
2.2 released
http://repos.fedorapeople.org/repos/pulp/pulp/stable/2.2/

Note You need to log in before you can comment on or make changes to this bug.