Bug 989632 - BUG: using smp_processor_id() in preemptible [00000000 00000000] code: hpsa
BUG: using smp_processor_id() in preemptible [00000000 00000000] code: hpsa
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
2.4
Unspecified Unspecified
unspecified Severity unspecified
: 2.4
: ---
Assigned To: John Kacur
MRG Quality Engineering
:
Depends On: 989629
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 12:50 EDT by John Kacur
Modified: 2013-10-01 12:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: hpsa driver used smp_processor_id() in preemptable context Consequence: Oops backtrace generated Fix: Convert to use raw_smp_processor_id() Result: No backtrace
Story Points: ---
Clone Of: 989629
Environment:
Last Closed: 2013-10-01 12:47:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Kacur 2013-07-29 12:50:30 EDT
+++ This bug was initially created as a clone of Bug #989629 +++

BUG: using smp_processor_id() in preemptible [00000000 00000000] code: modprobe/2493
caller is enqueue_cmd_and_start_io+0x57/0x230 [hpsa]
Pid: 2493, comm: modprobe Not tainted 3.6.11.5-rt37.53.el6rt.x86_64.trace #1
Call Trace:
 [<ffffffff81280623>] debug_smp_processor_id+0x123/0x150
 [<ffffffffa0092297>] enqueue_cmd_and_start_io+0x57/0x230 [hpsa]
 [<ffffffffa0092522>] hpsa_scsi_do_simple_cmd_with_retry+0xb2/0x2e0 [hpsa]
 [<ffffffffa00941e0>] hpsa_scsi_do_inquiry+0xb0/0x110 [hpsa]
 [<ffffffffa0096b07>] ? hpsa_init_one+0x1657/0x1b50 [hpsa]
 [<ffffffffa0096b2e>] hpsa_init_one+0x167e/0x1b50 [hpsa]
 [<ffffffff812975d9>] local_pci_probe+0x79/0x100
 [<ffffffff81298aa9>] pci_device_probe+0x109/0x130
 [<ffffffff8134f59a>] ? driver_sysfs_add+0x7a/0xb0
 [<ffffffff8134f6ff>] driver_probe_device+0x8f/0x230
 [<ffffffff8134f94b>] __driver_attach+0xab/0xb0
 [<ffffffff8134f8a0>] ? driver_probe_device+0x230/0x230
 [<ffffffff8134dabc>] bus_for_each_dev+0x6c/0xa0
 [<ffffffff8134f51e>] driver_attach+0x1e/0x20
 [<ffffffff8134ee47>] bus_add_driver+0xc7/0x250
 [<ffffffffa0017000>] ? 0xffffffffa0016fff
 [<ffffffff8134ffd4>] driver_register+0x74/0x160
 [<ffffffffa0017000>] ? 0xffffffffa0016fff
 [<ffffffff81298da5>] __pci_register_driver+0x85/0x100
 [<ffffffff810754d5>] ? __blocking_notifier_call_chain+0x65/0x80
 [<ffffffffa001701e>] hpsa_init+0x1e/0x20 [hpsa]
 [<ffffffff810001c2>] do_one_initcall+0x42/0x170
 [<ffffffff810abd6a>] sys_init_module+0x11a/0x17a0
 [<ffffffff810a9450>] ? free_notes_attrs+0x60/0x60
 [<ffffffff81544d92>] system_call_fastpath+0x16/0x1b
scsi0 : hpsa
Comment 1 John Kacur 2013-07-29 13:12:08 EDT
Fix is here:
https://patchwork.kernel.org/patch/2834206/
Comment 2 John Kacur 2013-07-30 09:54:13 EDT
fix in 3.8.13-rt14.18
Comment 6 errata-xmlrpc 2013-10-01 12:47:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1398.html

Note You need to log in before you can comment on or make changes to this bug.