Bug 989659 - when running with nvidia proprietary drivers, xorg hangs on black screen
when running with nvidia proprietary drivers, xorg hangs on black screen
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 13:10 EDT by Tomas Tomecek
Modified: 2014-02-24 02:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-24 02:00:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Tomecek 2013-07-29 13:10:02 EDT
I was trying to install nvidia's proprietary drivers recently to check if they perform better than nouveau. Unfortunately I was stuck on black screen most of the time. I read several threads [1] [2] on nvidia forums and nvidia employee provided xorg patches which should fix the problem. Would it be possible for you to apply those patches [3] [4]? If so, I have no problem with testing the patched rpm. If you don't have time, I can patch a build myself and then provide information here how it went.

[1] https://devtalk.nvidia.com/default/topic/539322/linux/blank-screen-with-319-12-on-optimus-laptop/5/
[2] https://devtalk.nvidia.com/default/topic/551709/linux/319-32-the-infamous-blank-black-screen-/
[3] http://cgit.freedesktop.org/xorg/xserver/commit/?h=server-1.14-branch&id=54b125d1751385bcfc3c1b51d21ee6a7dc14143b
[4] http://patchwork.freedesktop.org/patch/13598/
Comment 1 Sergio Monteiro Basto 2013-07-30 16:52:47 EDT
on Fedora 19 use HEAD of 
http://cgit.freedesktop.org/xorg/xserver/commit/?h=server-1.14-branch 

but I saw some bugs related with property drives , if you want install it use 
rpmfusion.org  ( http://rpmfusion.org/Configuration ) 
I test it myself and don't had any problem .
Comment 2 Tomas Tomecek 2013-07-31 02:24:47 EDT
I've tried it yesterday (xorg with those 2 patches; 1st one is already applied in official repository) and I didn't manage to make it work. X server was failing because of something (don't have logs here). Also the driver is not working with newest 3.10 kernel.

(In reply to Sergio Monteiro Basto from comment #1)
> on Fedora 19 use HEAD of 
> http://cgit.freedesktop.org/xorg/xserver/commit/?h=server-1.14-branch 
> 
> but I saw some bugs related with property drives , if you want install it
> use 
> rpmfusion.org  ( http://rpmfusion.org/Configuration ) 
> I test it myself and don't had any problem .

I wanted to try newest beta version of the driver. This one is not packaged in stable branch of RPM fusion. Don't know if there is some updates-testing repo the one in Fedora's repositories.
As I said, I just want to try the driver.
Comment 3 Tomas Tomecek 2014-02-24 02:00:30 EST
Don't have these problems anymore.

Note You need to log in before you can comment on or make changes to this bug.