Bug 989745 - RHS 2.0 (glusterfs 3.3) native client incompatible with RHS 2.1 (glusterfs 3.4) server
RHS 2.0 (glusterfs 3.3) native client incompatible with RHS 2.1 (glusterfs 3....
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Amar Tumballi
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 16:11 EDT by Dustin Black
Modified: 2013-12-18 19:09 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.31rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:24:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 446583 None None None Never

  None (edit)
Description Dustin Black 2013-07-29 16:11:36 EDT
Description of problem:
Unable to mount a RHS 2.1 volume export via glusterfs 3.3 client.

According to gluster.org documentation, these versions should be compatible.

http://www.gluster.org/author/johnmark/
http://www.gluster.org/author/vijay-bellur/


$ sudo mount.glusterfs 192.168.2.241:rep01 /mnt/test2
Mount failed. Please check the log file for more details.

$ sudo tail /var/log/glusterfs/mnt-test2.log 
[2013-07-29 20:03:55.505694] I [glusterfsd.c:1670:main] 0-/usr/sbin/glusterfs: Started running /usr/sbin/glusterfs version 3.3.2
[2013-07-29 20:03:55.518272] E [glusterfsd-mgmt.c:1550:mgmt_getspec_cbk] 0-glusterfs: failed to get the 'volume file' from server
[2013-07-29 20:03:55.518323] E [glusterfsd-mgmt.c:1618:mgmt_getspec_cbk] 0-mgmt: failed to fetch volume file (key:rep01)
[2013-07-29 20:03:55.518431] W [glusterfsd.c:838:cleanup_and_exit] (-->/usr/lib64/libgfrpc.so.0(rpc_clnt_notify+0xad) [0x7fcba9b2736d] (-->/usr/lib64/libgfrpc.so.0(rpc_clnt_handle_reply+0xa5) [0x7fcba9b268e5] (-->/usr/sbin/glusterfs(mgmt_getspec_cbk+0x297) [0x7fcbaa1da8a7]))) 0-: received signum (0), shutting down
[2013-07-29 20:03:55.518449] I [fuse-bridge.c:4655:fini] 0-fuse: Unmounting '/mnt/test2'.


# tail -1 etc-glusterfs-glusterd.vol.log
[2013-07-29 20:03:55.523396] I [glusterd-handshake.c:194:_client_supports_volume] 0-glusterd: Client 192.168.2.160:1023 (1 -> 1) doesn't support required op-version (2). Rejecting volfile request.
Comment 4 Dustin Black 2013-07-30 12:46:36 EDT
(In reply to Vijay Bellur from comment #3)
> Can you please try with "volume set <volname> open-behind off" ?
> 
> Also, note that it is recommended to use downstream glusterfs clients for
> accessing RHS. What does glusterfs --version read on the client?

After ensuring I have hostname resolution of the server from the client and disabling the open-behind volume option, I am able to mount via the native client from a RHEL 6 machine with GlusterFS 3.3 downstream bits.

Will we be addressing this compatibility caveat via the release documentation, or do we need to address via a configuration change to ensure default compatibility?
Comment 5 Amar Tumballi 2013-09-06 07:37:16 EDT
Dustin, this is addressed as part of new release... the RHS2.1 GA will be compatible with older clients. Will mark it ON_QA, can you mark it VERIFIED with newer builds?
Comment 6 Dustin Black 2013-09-06 10:17:42 EDT
(In reply to Amar Tumballi from comment #5)
> Dustin, this is addressed as part of new release... the RHS2.1 GA will be
> compatible with older clients. Will mark it ON_QA, can you mark it VERIFIED
> with newer builds?

I don't generally modify BZ statuses because I'm not in Engineering and don't fully understand the implications of the status changes.
Comment 7 Sachidananda Urs 2013-09-07 05:41:01 EDT
Tested out 2.0 clients with 2.1 servers:

U4 Clients and 2.1 servers
U5 Clients and 2.1 servers
U6 Clients and 2.1 servers

And

2.1 servers and U6 clients. Works good, marking verified.
Comment 9 Scott Haines 2013-09-23 18:24:59 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.