Bug 989830 - kdeplasma-addons depends on libqwt.so.5, but Fedora 19 contains libqwt.so.6
kdeplasma-addons depends on libqwt.so.5, but Fedora 19 contains libqwt.so.6
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdeplasma-addons (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-29 23:10 EDT by Simon Guest
Modified: 2013-07-31 06:05 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 06:05:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Guest 2013-07-29 23:10:01 EDT
Description of problem:
kdeplasma-addons depends on libqwt.so.5, but Fedora 19 contains libqwt.so.6

Version-Release number of selected component (if applicable):
4.10.5-1.fc19

How reproducible:
Every time

Steps to Reproduce:
1. Install new Fedora 19, with KDE desktop
2. yum update --skip-broken
3. yum update

Actual results:
Can't update kdeplasma-addons because of missing libqwt.so.5

Expected results:
Version of kdeplasma-addons which depends on available libqwt.so.6

Additional info:

That's all!

cheers,
Simon
Comment 1 Rex Dieter 2013-07-30 08:40:28 EDT
Shouldn't be a problem, F19 includes both libqwt.so.5 and libqwt.so.6,

$ rpm -q -f /usr/lib64/libqwt.so.5
qwt5-qt4-5.2.2-22.fc19.x86_64

$ rpm -q -f /usr/lib64/libqwt.so.6
qwt-6.0.1-3.fc19.x86_64

$ rpm -q kdeplasma-addons qwt5-qt4 
kdeplasma-addons-4.10.5-1.fc19.x86_64
qwt5-qt4-5.2.2-22.fc19.x86_64

Can you post the verbose/exact error messages you receive on update?
Comment 2 Simon Guest 2013-07-31 01:02:54 EDT
Sorry, I have made a mistake here.  This turns out to be a no-bug.

I mirrored fedora/linux/releases/19/Fedora/x86_64/os, when I should have mirrored fedora/linux/releases/19/Everything/x86_64/os.  Once I fixed this, all is well.

Thanks for your patience, and sorry for wasting your time.

cheers,
Simon

Note You need to log in before you can comment on or make changes to this bug.