This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 989858 - avoid setting insecure LD_LIBRARY_PATH
avoid setting insecure LD_LIBRARY_PATH
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: scripts (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Ric Wheeler
:
Depends On: 989514 989689
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 01:15 EDT by Amar Tumballi
Modified: 2014-04-17 07:44 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 989689
Environment:
Last Closed: 2014-04-17 07:44:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Amar Tumballi 2013-07-30 01:15:56 EDT
+++ This bug was initially created as a clone of Bug #989689 +++

mount.glusterfs uses insecure LD_LIBRARY_PATH.  We would need to avoid using it as it is not advised as a general practice.
Comment 1 Anand Avati 2013-07-30 01:22:12 EDT
REVIEW: http://review.gluster.org/5423 (mount.glusterfs: remove use of LD_LIBRARY_PATH) posted (#1) for review on master by Amar Tumballi (amarts@redhat.com)
Comment 2 Anand Avati 2013-07-31 09:24:56 EDT
COMMIT: http://review.gluster.org/5423 committed in master by Anand Avati (avati@redhat.com) 
------
commit a960f929f341e7e56687227ef23b315a57780314
Author: Amar Tumballi <amarts@redhat.com>
Date:   Mon Jul 29 23:27:03 2013 +0530

    mount.glusterfs: remove use of LD_LIBRARY_PATH
    
    BUG: 989858
    Change-Id: Id7c3929a179e151b6d60d3382bd5310187bb2aa6
    Signed-off-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-on: http://review.gluster.org/5423
    Reviewed-by: Bala FA <barumuga@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 6 Niels de Vos 2014-04-17 07:44:28 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.