Bug 989888 - SELinux is preventing /var/lib/dkms/nvidia/325.05.03/build/conftest1641 from 'execute_no_trans' accesses on the file /var/lib/dkms/nvidia/325.05.03/build/conftest2703.
SELinux is preventing /var/lib/dkms/nvidia/325.05.03/build/conftest1641 from ...
Status: CLOSED DUPLICATE of bug 989843
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:51e2addd3b3e29c8fa38571e9a8...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 02:42 EDT by Moez Roy
Modified: 2013-07-30 04:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-30 04:36:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-07-30 02:42:49 EDT
Description of problem:
SELinux is preventing /var/lib/dkms/nvidia/325.05.03/build/conftest1641 from 'execute_no_trans' accesses on the file /var/lib/dkms/nvidia/325.05.03/build/conftest2703.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that conftest1641 should be allowed execute_no_trans access on the conftest2703 file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep conftest1641 /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:initrc_t:s0
Target Context                system_u:object_r:var_lib_t:s0
Target Objects                /var/lib/dkms/nvidia/325.05.03/build/conftest2703
                              [ file ]
Source                        conftest1641
Source Path                   /var/lib/dkms/nvidia/325.05.03/build/conftest1641
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-98.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.11-200.fc18.x86_64 #1 SMP Mon
                              Jul 22 21:04:50 UTC 2013 x86_64 x86_64
Alert Count                   2
First Seen                    2013-07-29 23:37:32 PDT
Last Seen                     2013-07-29 23:37:49 PDT
Local ID                      e8fc4768-df74-4179-a93d-d6f3a90ee0cb

Raw Audit Messages
type=AVC msg=audit(1375166269.790:308): avc:  denied  { execute_no_trans } for  pid=2712 comm="sh" path="/var/lib/dkms/nvidia/325.05.03/build/conftest2703" dev="dm-0" ino=918547 scontext=system_u:system_r:initrc_t:s0 tcontext=system_u:object_r:var_lib_t:s0 tclass=file


type=SYSCALL msg=audit(1375166269.790:308): arch=x86_64 syscall=execve success=yes exit=0 a0=16d6060 a1=16d6020 a2=16c07e0 a3=10 items=0 ppid=2703 pid=2712 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=conftest2703 exe=/var/lib/dkms/nvidia/325.05.03/build/conftest2703 subj=system_u:system_r:initrc_t:s0 key=(null)

Hash: conftest1641,initrc_t,var_lib_t,file,execute_no_trans

audit2allow

#============= initrc_t ==============
allow initrc_t var_lib_t:file execute_no_trans;

audit2allow -R
require {
	type initrc_t;
	type var_lib_t;
	class file execute_no_trans;
}

#============= initrc_t ==============
allow initrc_t var_lib_t:file execute_no_trans;


Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.11-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-07-30 04:36:55 EDT

*** This bug has been marked as a duplicate of bug 989843 ***

Note You need to log in before you can comment on or make changes to this bug.