Bug 989917 - lsmcli: ontap plugin not found
lsmcli: ontap plugin not found
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libstoragemgmt (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Tony Asleson
Bruno Goncalves
: Regression
Depends On:
Blocks: 737672
  Show dependency treegraph
 
Reported: 2013-07-30 03:25 EDT by Bruno Goncalves
Modified: 2013-07-30 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-30 12:56:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Goncalves 2013-07-30 03:25:37 EDT
Description of problem:
lsmcli is not able to connect to OnTap target because the plugin is not found.

lsmcli -u ontap://root@<target> -l VOLUMES
error: 311 msg: Plug-in /var/run/lsm/ipc/ontap not found! 

Version-Release number of selected component (if applicable):
libstoragemgmt-0.0.21-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.install libstoragemgmt-0.0.21-1.el7
2. start daemon
/usr/bin/lsmd
3.try to perform an operation
lsmcli -u ontap://root@<target> -l VOLUMES
Comment 3 Andy Grover 2013-07-30 12:38:16 EDT
seems like a libstoragemgmt issue, reassigning
Comment 4 Tony Asleson 2013-07-30 12:52:43 EDT
Release 0.0.21 placed each of the plug-ins in separate rpm packages so that users could install just what they needed.  


The following packages are available:

libstoragemgmt-debuginfo.x86_64
libstoragemgmt-devel.x86_64
libstoragemgmt-netapp-plugin.noarch
libstoragemgmt-nstor-plugin.noarch
libstoragemgmt-python.noarch
libstoragemgmt-smis-plugin.noarch
libstoragemgmt-targetd-plugin.noarch
libstoragemgmt.x86_64

Thanks,
Tony
Comment 5 Tony Asleson 2013-07-30 12:55:16 EDT
Make sure to restart the daemon after installing plug-in packages.

Note You need to log in before you can comment on or make changes to this bug.