Bug 99001 - Device or resource busy. Cannot open '/dev/sg0'. Cannot open SCSI driver.
Device or resource busy. Cannot open '/dev/sg0'. Cannot open SCSI driver.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: cdrecord (Show other bugs)
9
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-11 11:50 EDT by James Shanks
Modified: 2007-04-18 12:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-04 06:04:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screendump of up2date and cdrecord output (85.25 KB, image/png)
2003-08-18 09:44 EDT, James Shanks
no flags Details

  None (edit)
Description James Shanks 2003-07-11 11:50:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I first tried this with cdrecord-2.0-6, but after reading the bug reports I
upgraded to the latest rawhide version, but still have the problem.

cdrecord -scanbus produces the following error:

Cdrecord 2.0 (i686-pc-linux-gnu) Copyright (C) 1995-2002 J?rg Schilling
cdrecord: Device or resource busy. Cannot open '/dev/sg0'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.

Displaying /etc/hwconf reveals the following:

class: CDROM
bus: SCSI
detached: 0
device: scd0
driver: ignore
desc: "  atapi 12X DVD-ROM"
host: 1
id: 0
channel: 0
lun: 0
generic: sg1
-
class: CDROM
bus: SCSI
detached: 0
device: scd1
driver: ignore
desc: "Yamaha CRW2100E"
host: 1
id: 1
channel: 0
lun: 0
generic: sg2
-
class: TAPE
bus: SCSI
detached: 0
device: st
driver: ignore
desc: "Hp C1537A"
host: 0
id: 3
channel: 0
lun: 0
generic: sg0

It seems that cdrecord is having trouble getting past the tape drive, which is a
"real" SCSI device on an Adaptec controller.  The cd drives are both IDE
devices.  This wouldn't be a big problem except that some cd-rom burning front
ends try to detect the drives during startup (and crash).

Problem didn't show up on RH 7.3 or 8.0.



Version-Release number of selected component (if applicable):
cdrecord-2.0-11.1

How reproducible:
Always

Steps to Reproduce:
1.  run cdrecord -scanbus
2.
3.
    

Actual Results:  Produces error above.

Expected Results:  Should find the cdrom drives as in version 7.3 and 8.0.

Additional info:

Yes, removing the tape drive does make it work, but not a very good solution.
Comment 1 David Lawrence 2003-08-15 15:20:14 EDT
Are you logged in as root when running the cdrecord -scanbus command? I get this
error also when logged in as a normal user.
Comment 2 James Shanks 2003-08-15 17:10:58 EDT
Yes this was tried as root.  I just tried it again as root to verify.
Comment 3 Harald Hoyer 2003-08-18 07:17:54 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-252.html
Comment 4 James Shanks 2003-08-18 09:44:23 EDT
Created attachment 93711 [details]
Screendump of up2date and cdrecord output
Comment 5 James Shanks 2003-08-18 09:45:18 EDT
I just applied the patches.  The problem has not changed.
The best way to test this is to install a tape drive on an Adapted controller in
a system running RH9.  I've tried it on two now and it fails on both.
Comment 6 Harald Hoyer 2003-08-18 11:55:59 EDT
ok, I believe you :)
Comment 7 Scot Huntsberry 2003-08-21 21:08:54 EDT
I too applied the updates and still have the problem with the CD hanging. 
Additionaly, my system seems slower in general.
Comment 8 Harald Hoyer 2003-08-22 05:25:36 EDT
then we should report these issues to the author of cdrecord, cause in the
up2date version there are no RH specific patches anymore..
Comment 9 Jim Shanks 2003-08-22 16:47:21 EDT
Maybe this should be listed as a kernel problem, and not a cdrecord problem.  
RH 7.3 and 8.0 worked just fine.
Comment 10 Harald Hoyer 2003-10-24 08:45:00 EDT
can you please retry with the newest rawhide versions?
Comment 11 Harald Hoyer 2004-06-04 06:04:07 EDT
ok, cannot fix this...
Reopen, if the problem is still existing in newer Fedora versions.

Note You need to log in before you can comment on or make changes to this bug.