Bug 99006 - Error on preview
Summary: Error on preview
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
(Show other bugs)
Version: nightly
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Rafael H. Schloming
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-11 16:34 UTC by Tzu-Mainn Chen
Modified: 2014-12-01 23:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 21:37:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tzu-Mainn Chen 2003-07-11 16:34:40 UTC
Hi,

Someone at WebMD reported this bug when they try to preview their custom content item - previewing used to work, before their build was updated to ccm-cms-5.3.0.AUTO.33149-1-devel.  I tried it on my build, and I get the same error, so I don't think it's his settings (he uses 8.1.6; I'm using 8.1.7):

com.arsdigita.persistence.PersistenceException:  (root cause: com.arsdigita.db.DbNotAvailableException (root cause: com.arsdigita.db.DbNotAvailableException (root cause: java.sql.SQLException: Closed Connection)))
   at com.arsdigita.persistence.Session.freeConnection(Session.java:440)
   at com.arsdigita.persistence.Session$2.release(Session.java:160)
   at

(also in the log)

com.arsdigita.persistence.proto.engine.rdbms.RDBMSEngine$3: null (root cause: Closed Connection)
   at com.arsdigita.persistence.proto.engine.rdbms.RDBMSEngine.execute(RDBMSEngine.java:413)

Thanks,
Tzu-Mainn Chen

Comment 1 Richard Li 2003-07-11 17:58:38 UTC
Does it only happen on preview? Does it introduce any other failures after the
preview link is called?

This is prior to the UNION ALL optimization that bche introduced, so that is not
the culprit.

Comment 2 Rafael H. Schloming 2003-07-11 18:09:11 UTC
It looks like oracle is barfing on something and closing the connection. We
probably need to take a look at the oracle logs in order to figure out what the
culprit is here. It's possible this is the same behavior that Vadim sees with is
!isCommitted() fix.

Comment 3 Tzu-Mainn Chen 2003-07-11 18:17:05 UTC
Hi,

I'm working on alewife for the webmd stuff, so the Oracle logs should be on alewife, if that helps. . .

Thanks,
Tzu-Mainn Chen

Comment 4 Vadim Nasardinov 2003-07-11 18:22:33 UTC
I have a feeling, Rafi is right.  There is probably an earlier 
exception of the form 
 
java.sql.SQLException: ORA-03113: end-of-file on communication channel 
 
Mine looked like so: 
 
2003-07-09 14:51:51,270 [800-0] WARN  db.PreparedStatement - 
Connection[368061]::execute:: 
2003-07-09 14:51:51,270 [800-0] WARN  db.PreparedStatement - select is_folder 
as c_1, 
       is_deleted as c_2, 
       master_id as c_3, 
       default_domain_class as c_4, 
       name as c_5, 
       object_type as c_6, 
       has_live_version as c_7, 
       version as c_8, 
       item_id as c_9, 
       display_name as c_10 
from ( 
    select  
      a.object_type, a.display_name, a.default_domain_class, 
      v.master_id, v.is_deleted, 
      i.item_id, i.parent_id, i.version, i.name, 
      case when exists (select 1 
                        from cms_items 
                        where master_id = i.item_id) 
        then 1 else 0 end as has_live_version, 
      case when exists (select 1  
                        from cms_folders f 
			where i.item_id = f.folder_id) 
        then 1 else 0 end as is_folder			 
    from  
      cms_items i,  
      acs_objects a,  
      vc_objects v 
    where  
      i.item_id = a.object_id 
    and  
      i.item_id = v.object_id 
    and  
      i.parent_id = ? 
    and 
      i.version = ? 
    and 
      v.is_deleted = '0' 
    and (exists (select 1 from cms_folders f 
                 where f.folder_id = i.item_id) 
         or 
         exists (select 1 from cms_bundles b 
	         where b.bundle_id = i.item_id))) st_ 
where (1 = 1 and name = ?) 
order by is_folder desc, item_id desc 
2003-07-09 14:51:51,271 [800-0] WARN  db.PreparedStatement - Bind Vars:: [:3 = 
new-versioning,:2 = draft,:1 = 105,] 
2003-07-09 14:51:51,279 [800-0] WARN  db.PreparedStatement - threw exception:  
java.sql.SQLException: ORA-03113: end-of-file on communication channel 
 
oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:168) 
oracle.jdbc.oci8.OCIDBAccess.check_error(OCIDBAccess.java:1597) 
oracle.jdbc.oci8.OCIDBAccess.fetch(OCIDBAccess.java:1410) 
oracle.jdbc.driver.OracleStatement.doExecuteQuery(OracleStatement.java:1681) 
oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1870) 
oracle.jdbc.driver.OraclePreparedStatement.executeUpdate(OraclePreparedStatement.java:363) 
oracle.jdbc.driver.OraclePreparedStatement.execute(OraclePreparedStatement.java:407) 
com.arsdigita.db.PreparedStatement.doExecute(PreparedStatement.java:213) 
com.arsdigita.db.PreparedStatement.execute(PreparedStatement.java:184) 
com.redhat.persistence.engine.rdbms.RDBMSEngine.execute(RDBMSEngine.java:402) 
com.redhat.persistence.engine.rdbms.RDBMSEngine.execute(RDBMSEngine.java:373) 
com.redhat.persistence.engine.rdbms.RDBMSEngine.execute(RDBMSEngine.java:197) 
com.redhat.persistence.engine.rdbms.RDBMSEngine.execute(RDBMSEngine.java:188) 
com.redhat.persistence.Cursor.execute(Cursor.java:110) 
com.redhat.persistence.Cursor.next(Cursor.java:94) 
com.arsdigita.persistence.DataQueryImpl.next(DataQueryImpl.java:431) 
com.arsdigita.persistence.DataQueryDecorator.next(DataQueryDecorator.java:75) 
com.arsdigita.domain.DomainQuery.next(DomainQuery.java:84) 
com.arsdigita.cms.Folder.getItem(Folder.java:250) 
com.arsdigita.cms.dispatcher.MultilingualItemResolver.getItemFromLiveURL(MultilingualItemResolver.java:719) 
com.arsdigita.cms.dispatcher.MultilingualItemResolver.getItemFromLiveURL(MultilingualItemResolver.java:711) 
com.arsdigita.cms.dispatcher.MultilingualItemResolver.getItem(MultilingualItemResolver.java:188) 
com.arsdigita.cms.ContentSectionServlet.getItem(ContentSectionServlet.java:261) 
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:106) 
 
 

Comment 5 Rafael H. Schloming 2003-07-11 18:40:51 UTC
Unfortunately I don't have access to alewife. I would suggest turning
db.PreparedStatement up to WARN, reproducing the problem and looking for
something along the lines of what vadim posted. Once you have the query you can
verify in sqlplus if that is indeed causing an ORA 0600 and then we might have a
chance at figuring out why, or at least we'll have something to search metalink for.

Comment 6 Tzu-Mainn Chen 2003-07-11 19:29:15 UTC
Actually, the error is caused by the exact same SQL block that you saw, so it looks like it's not even touching anything custom.

Comment 7 Jon Orris 2003-07-15 18:37:28 UTC
We aren't able to replicate this on either Reusia database, 8.1.7.4 and 9.2.0.2.
I'd suggest upgrading oracle and/or Troika to the tip.



Note You need to log in before you can comment on or make changes to this bug.