Bug 990066 - Dist-geo-rep: 'gluster vol geo <master_vol> status' command shows only one node status and 'gluster volume geo <master_vol> <slave_ip>::<slave_vol> status' throws an error
Dist-geo-rep: 'gluster vol geo <master_vol> status' command shows only one no...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
high Severity low
: ---
: ---
Assigned To: Avra Sengupta
amainkar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 06:28 EDT by Rachana Patel
Modified: 2015-04-20 07:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:38:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2013-07-30 06:28:26 EDT
Description of problem:
Dist-geo-rep: 'gluster vol geo <master_vol> status' command shows only one node status and 'gluster volume geo <master_vol> <slave_ip>::<slave_vol> status' throws an error

Version-Release number of selected component (if applicable):
3.4.0.13rhs-1.el6rhs.x86_64

How reproducible:
hit it twice today, dont know exact steps to reproduce

Steps to Reproduce:
[root@DVM4 geo-replication]# gluster volume geo test5 status
NODE                           MASTER   SLAVE                                              HEALTH         UPTIME       
-----------------------------------------------------------------------------------------------------------------------
DVM4.lab.eng.blr.redhat.com    test5    ssh://rhsauto018.lab.eng.blr.redhat.com::slave5    Not Started    N/A  
        
[root@DVM4 geo-replication]# gluster volume geo test5  rhsauto018.lab.eng.blr.redhat.com::slave5 status
Commit failed on 10.70.37.100. Please check log file for details.
Commit failed on 10.70.37.62. Please check log file for details.
Commit failed on 10.70.37.141. Please check log file for details.
Commit failed on 10.70.37.85. Please check log file for details.
Commit failed on 10.70.37.95. Please check log file for details.
geo-replication command failed

Actual results:


Expected results:


Additional info:
Comment 2 Avra Sengupta 2013-08-05 03:48:50 EDT
Fixed with https://code.engineering.redhat.com/gerrit/#/c/10827/
Comment 3 Rachana Patel 2013-08-08 06:22:51 EDT
verified with -3.4.0.18rhs-1.el6rhs.x86_64
working as per expected result , hence moving to verified
Comment 4 Scott Haines 2013-09-23 18:38:49 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 5 Scott Haines 2013-09-23 18:41:30 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.