Bug 990101 - RHEL guest could not detect the second monitor by virt-viewer.
RHEL guest could not detect the second monitor by virt-viewer.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 07:35 EDT by hyao@redhat.com
Modified: 2013-11-12 23:30 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 23:30:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Vimal Patel 2013-11-12 16:13:38 EST
I see the same issue.  Display 2 doesn't detect the 2nd monitor

Testing Configuration:
Client: RHEL 7  RHEL-7.0-20131106.n.1

virt-viewer-0.5.7-2.el7.x86_64
usbredir-0.6-5.el7.x86_64

Guest: RHEL 6.5 RC1.2
spice-vdagent-0.14.0.2-el6.x86_64
xorg-x11-drv-qxl-0.1.0-7.el6.x86_64

Host: RHEL 7  RHEL-7.0-20131106.n.1
spice-server-0.12.4-3.el7.x86_64
libvirt-1.1.1-11.el7.x86_64
qemu-kvm-1.5.3-13.el7.x86_64

More information on the issue:
On Virt Manager, I only set 2 displays (2 QXL Video devices).
When connecting to the VM, it shows Displays 1,2,3,and 4 being available, so this may be another bug I believe only Display 1 & 2 should be available as choices for the user.

Then if I try to use 2 monitors using 1 & 2, display 2 never works.  Displays 3 & 4 both work.  So I can use 1,3,4, but 2 never works.
Comment 3 Vimal Patel 2013-11-12 16:41:44 EST
I also see the following log message from remote-viewer:
(remote-viewer:7735): remote-viewer-CRITICAL **: virt_viewer_app_display_added: assertion 'virt_viewer_app_get_nth_window(self, nth) == NULL' failed.
Comment 4 Marc-Andre Lureau 2013-11-12 16:53:55 EST
(In reply to Vimal Patel from comment #2)
> I see the same issue.  Display 2 doesn't detect the 2nd monitor
> 
> Testing Configuration:
> Client: RHEL 7  RHEL-7.0-20131106.n.1
> 
> virt-viewer-0.5.7-2.el7.x86_64
> usbredir-0.6-5.el7.x86_64
> 
> Guest: RHEL 6.5 RC1.2
> spice-vdagent-0.14.0.2-el6.x86_64
> xorg-x11-drv-qxl-0.1.0-7.el6.x86_64
> 
> Host: RHEL 7  RHEL-7.0-20131106.n.1
> spice-server-0.12.4-3.el7.x86_64
> libvirt-1.1.1-11.el7.x86_64
> qemu-kvm-1.5.3-13.el7.x86_64
> 
> More information on the issue:
> On Virt Manager, I only set 2 displays (2 QXL Video devices).
> When connecting to the VM, it shows Displays 1,2,3,and 4 being available, so
> this may be another bug I believe only Display 1 & 2 should be available as
> choices for the user.

Multiple QXL device with Linux guest/xrandr is no supported for multimonitor & arbitrary/resolution. Please try again with a single QXL device.
Comment 5 hyao@redhat.com 2013-11-12 23:30:50 EST
Restest with the following packages on rhel7. 
# rpm -qa libvirt virt-viewer spice-*
spice-glib-0.20-6.el7.x86_64
libvirt-1.1.1-12.el7.x86_64
spice-server-0.12.4-3.el7.x86_64
spice-gtk3-0.20-6.el7.x86_64
virt-viewer-0.5.7-2.el7.x86_64
spice-xpi-2.8-4.el7.x86_64
spice-vdagent-0.14.0-5.el7.x86_64


1.Install a rhel6.5 guest with one  spice+qxl device and spicevmc channel
2.Run #virt-viewer guestname and remote-viewer spice://127.0.0.1:5900
3. Check the 4 available displays and all the 4 displays works. 

Based on comment 4 "Multiple QXL device with Linux guest/xrandr is no supported for multimonitor & arbitrary/resolution. Please try again with a single QXL device.",  and since add one qxl device works I close this bug.

Note You need to log in before you can comment on or make changes to this bug.