Bug 990154 - After Rebalance , with non root user, permissions on some link files change
After Rebalance , with non root user, permissions on some link files change
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: distribute (Show other bugs)
mainline
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Nagaprasad Sathyanarayana
: Reopened
Depends On: 904919 990548
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-30 09:43 EDT by shishir gowda
Modified: 2016-02-17 19:19 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 904919
Environment:
Last Closed: 2014-04-17 07:44:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-07-30 09:44:51 EDT
REVIEW: http://review.gluster.org/5434 (cluster/dht: Fix non-regular file ownership during rebalance) posted (#1) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 2 Anand Avati 2013-07-31 00:30:32 EDT
REVIEW: http://review.gluster.org/5434 (cluster/dht: Fix non-regular file ownership during rebalance) posted (#2) for review on master by Shishir Gowda (sgowda@redhat.com)
Comment 3 Anand Avati 2013-07-31 06:43:26 EDT
COMMIT: http://review.gluster.org/5434 committed in master by Anand Avati (avati@redhat.com) 
------
commit ac2cd684c2d8fa4a66800a6cc98f6c5c562b4b7f
Author: shishir gowda <sgowda@redhat.com>
Date:   Tue Jul 30 17:22:58 2013 +0530

    cluster/dht: Fix non-regular file ownership during rebalance
    
    Currently non-regular files were created as root:root, and
    their ownership never healed during rebalance process.
    
    Also, in dht_linkfile_attr_heal, we have to heal the linkfiles
    as default, as currently linkfiles are created as root:root.
    
    That check existed, as earlier linkfiles were created as
    frame->root->uid/gid
    
    Change-Id: I6cd88361b81bdd500e15bc47b623f5db8eec88e9
    BUG: 990154
    Signed-off-by: shishir gowda <sgowda@redhat.com>
    Reviewed-on: http://review.gluster.org/5434
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 6 Niels de Vos 2014-04-17 07:44:32 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.