Bug 990173 - gvfs-gphoto crashing after connecting mobile device to transfer data
gvfs-gphoto crashing after connecting mobile device to transfer data
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gvfs (Show other bugs)
6.5
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Ondrej Holy
Desktop QE
:
Depends On:
Blocks: 1002711
  Show dependency treegraph
 
Reported: 2013-07-30 10:01 EDT by Siddharth
Modified: 2015-09-18 09:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-18 09:55:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
corefile (1.00 MB, application/x-core)
2013-07-30 10:22 EDT, Siddharth
no flags Details

  None (edit)
Description Siddharth 2013-07-30 10:01:16 EDT
Description of problem:
gvfs-gphoto crashed in function dtoh32ap() while copying data from mobile to dekstop

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux - 6.4
gvfs-gphoto2-1.4.3-15.el6

How reproducible:
random

Steps to Reproduce:
1. Connect  your samsung or any mobile device to desktop
2. Try to copy data from desktop to mobile / mobile to desktop
3. You will observe crash

Actual results:
gvfs-gphoto crashing

Expected results:
gvfs-gphoto should not crashe

Additional info:
Comment 2 Siddharth 2013-07-30 10:22:02 EDT
Created attachment 780695 [details]
corefile
Comment 4 Thomas Cameron 2013-07-30 11:30:39 EDT
FWIW, this happens every time I connect my S4 to my RHEL 6 workstation. I can reproduce it at will. 

Also, I cannot browse the contents of my phone from my PC, whether the phone is in camera or media device mode. It's quite irritating.
Comment 8 Siddharth 2013-10-07 12:09:43 EDT
Hello,

Sorry for not asking proper question. I just want to know the status of this bug.
It is still NEW? When can it get fixed. Also want to know whether my analysis is correct or not?
Comment 10 RHEL Product and Program Management 2013-10-13 19:19:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 16 Chris Williams 2015-09-18 09:55:40 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 6 and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.