Bug 99036 - Remove "Sawfish window manager" menu (was: "move menu")
Remove "Sawfish window manager" menu (was: "move menu")
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-menus (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Seth Nickell
: FutureFeature
Depends On: 99044
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-12 06:20 EDT by Toralf
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-16 13:35:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toralf 2003-07-12 06:20:55 EDT
Description of problem:
It seems a bit unnecessary to have 3 Preverences menu levels. "Sawfish window
manager" folder should be a direct descendant of Preferences, I think.

Version-Release number of selected component (if applicable):
0.38-1
Comment 1 Havoc Pennington 2003-07-12 10:41:52 EDT
Both "Sawfish" and "window manager" are arcana most people don't understand; 
the other option really is to remove the menu item entirely.

There are already too many items directly under Preferences
Comment 2 Toralf 2003-07-12 12:55:25 EDT
Of course, the menu name doesn't have to "Sawfish window manager", and there are
probably other entries in Preferences that could be moved.

But, if you'll allow me to make another suggestion... (See new title + dependency.)
Comment 3 Havoc Pennington 2003-07-12 13:35:05 EDT
The other suggestion is of course the right one, but it involves writing 
a significant chunk of new code, which we don't plan to do for Sawfish
since it's not the default WM. We would incorporate that change if 
it were done by the upstream Sawfish developers, though.
Comment 4 Toralf 2003-07-23 06:43:21 EDT
gnome-window-properties correctly starts sawfish configurator with current CVS
version of Sawfish. Also, with a package built using .spec file on CVS (with a
couple of minor adjustments necessary to include all files correctly),
individual .desktop files for preferences aren't included, so I get exactly the
setup I want. Any change for a new package in Red Hat updates?

Another part of the story is that my primary reason for wanting Sawfish in the
first place, is that it allows me to work around GNOME's default of putting the
panel in front of all windows, which I find incredibly annoying...

Note You need to log in before you can comment on or make changes to this bug.