Bug 99037 - Preferred Apps Framework (was Wanted: Generic "E-mail" item in Internet menu)
Preferred Apps Framework (was Wanted: Generic "E-mail" item in Internet menu)
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: redhat-menus (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
: FutureFeature, MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-12 07:14 EDT by Toralf
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-12 12:25:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Toralf 2003-07-12 07:14:32 EDT
Description of problem:
The Internet menu should perhaps contain a button "E-mail"/"Mail User
Agent"/"Mailer GUI"/whatever that would start the user's preferred application,
just like the web browser entry is supposed to start the "preferred" web browser
(Presumably. The current version starts mozilla regardless of the user settings,
of course, but there is a separate bugzilla entry on that.)

The .desktop entry would have an "Exec" pointing to something like:

#!/bin/sh

GNOME_MAILER="`gconftool-2 -g /desktop/gnome/url-handlers/mailto/command | cut
-d ' ' -f 1`"

if [ -n "$GNOME_MAILER" ]
then
  exec $GNOME_MAILER
else
  exec mozilla -mail
fi


Version-Release number of selected component (if applicable):
0.38-1
Comment 1 Havoc Pennington 2003-07-12 10:47:39 EDT
The naming convention is supposed to be "Mozilla Web Browser", 
"Evolution Email", etc., including the specific app name, which we can't 
do with a generic entry. Some menu items don't follow this convention, 
sometimes on purpose (Calculator, too insignificant to have a name), 
but sometimes it's a bug.

Anyway, it's deliberate that the web browser entry is now always mozilla
rather than being genericized.

If we had a solid "preferred applications" setting somewhere, then the way to do
this would be to rotate the menu item for your preferred browser into the menu.
e.g. if you preferred Mozilla, then you would get "Mozilla Web Browser" and 
if you preferred Galeon you would get "Galeon Web Browser"

But we don't have this, and it has to happen upstream because of the 
architectural/long-term impact.
Comment 2 Toralf 2003-07-12 12:08:02 EDT
Fair enough. A couple of more though:

1. There are currently two entries for the Mozilla web browser; one directly
under "Internet Applications", one under "More Internet Applications". The
former is installed by redhat-menus package, the latter by mozilla itself. Seems
to me that a cleanup is needed.

2. Preferences does have a "Preferred Applications". If the settings have no
effect, this entry should probably be removed.
Comment 3 Havoc Pennington 2003-07-12 12:25:01 EDT
1. I'm 99% sure is already filed as a separate bug report
2. is GNOME-specific and doesn't really do the right thing 
   (it changes what browser is launched if you click on on url 
   in gnome apps, but doesn't affect the menus)

Note You need to log in before you can comment on or make changes to this bug.