Bug 990420 - Dist-geo-rep : geo rep status should show detail info. like file count, byte counts, replicated and remaining. files deleted & remaining
Dist-geo-rep : geo rep status should show detail info. like file count, byte ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: Avra Sengupta
: TestBlocker
Depends On: 988852
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 03:35 EDT by Avra Sengupta
Modified: 2014-04-17 07:44 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 988852
Environment:
Last Closed: 2014-04-17 07:44:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-07-31 03:39:44 EDT
REVIEW: http://review.gluster.org/5441 (glusterd/cli : status detail cli) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 2 Anand Avati 2013-08-06 11:35:40 EDT
REVIEW: http://review.gluster.org/5441 (glusterd/cli : status detail cli) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 3 Anand Avati 2013-08-08 03:39:24 EDT
REVIEW: http://review.gluster.org/5441 (glusterd/cli : status detail cli) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 4 Anand Avati 2013-08-13 01:55:55 EDT
REVIEW: http://review.gluster.org/5441 (gsyncd / geo-rep: Introduce basic crawl instrumentation) posted (#4) for review on master by Venky Shankar (vshankar@redhat.com)
Comment 5 Anand Avati 2013-08-13 01:56:50 EDT
REVIEW: http://review.gluster.org/5590 (glusterd/cli: Geo-Replication "status detail" cmd) posted (#1) for review on master by Venky Shankar (vshankar@redhat.com)
Comment 6 Anand Avati 2013-09-03 05:57:35 EDT
REVIEW: http://review.gluster.org/5590 (glusterd/cli: Geo-Replication "status detail" cmd) posted (#2) for review on master by Venky Shankar (vshankar@redhat.com)
Comment 7 Anand Avati 2013-09-03 06:03:27 EDT
REVIEW: http://review.gluster.org/5441 (gsyncd / geo-rep: Introduce basic crawl instrumentation) posted (#5) for review on master by Venky Shankar (vshankar@redhat.com)
Comment 8 Anand Avati 2013-09-04 22:50:50 EDT
COMMIT: http://review.gluster.org/5441 committed in master by Anand Avati (avati@redhat.com) 
------
commit 603119c57c5055e17693d47b9965216954f45247
Author: Venky Shankar <vshankar@redhat.com>
Date:   Wed Jul 31 13:01:30 2013 +0530

    gsyncd / geo-rep: Introduce basic crawl instrumentation
    
    This patch extends the persistent instrumentation work done by
    Aravinda (@avishwa), by introducing a handfull of instrumentation
    variables for crawl. These variables are "pulled up" by glusterd
    in the event of a geo-replication status cli command and looks
    something like below:
    
    "Uptime=00:21:10;FilesSyned=2982;FilesPending=0;BytesPending=0;DeletesPending=0;"
    
    "FilesPending", "BytesPending" and "DeletesPending" are short-lived
    variables that are non-zero when a changelog is being processes (ie.
    when an active sync in ongoing). After a successfull changelog process
    "FilesPending" is summed up into "FilesSynced". The three short-lived
    variabled are then reset to zero and the data is persisted
    
    Additionally this patch also reverts some of the changes made for
    BZ #986929 (those were not needed).
    
    Change-Id: I948f1a0884ca71bc5e5bcfdc017d16c8c54fc30b
    BUG: 990420
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-on: http://review.gluster.org/5441
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 9 Anand Avati 2013-09-04 22:51:30 EDT
COMMIT: http://review.gluster.org/5590 committed in master by Anand Avati (avati@redhat.com) 
------
commit fe98c2902fd13dac93e5add60d1f10b2cef8ae37
Author: Venky Shankar <vshankar@redhat.com>
Date:   Mon Aug 12 22:09:45 2013 +0530

    glusterd/cli: Geo-Replication "status detail" cmd
    
    Provides detailed status info in the following format
    
                        MASTER <master-vol>  SLAVE <slave-vol>
    
    NODE   HEALTH   UPTIME  FILES SYNCD  FILES PENDING  BYTES PENDING  DELETES PENDING
    -----------------------------------------------------------------------------------
    
    This patch introdues "status detail" command to show crawl related
    information in CLI. These values are "pulled" from gsyncd when
    "status detail" is executed.
    
    Change-Id: I1fdaf7180eacce054a864d34971dc160bd7301e1
    BUG: 990420
    Signed-off-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-on: http://review.gluster.org/5590
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Tested-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 10 Niels de Vos 2014-04-17 07:44:48 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.