This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 990490 - Error msg returned when trying to get specific process variable log via REST
Error msg returned when trying to get specific process variable log via REST
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER2
: 6.0.0
Assigned To: Marco Rietveld
Radovan Synek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 05:50 EDT by Radovan Synek
Modified: 2016-09-20 01:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:13:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radovan Synek 2013-07-31 05:50:47 EDT
After I launched a process I wanted to get a history of changes of a variable 'count':
http://localhost:8080/business-central/rest/runtime/org.jboss.qa.bpms:clustering:1.0.0.Final/history/instance/4/variable/count

However, instead of requested data I got error msg:
<response>
    <status>BAD_REQUEST</status>
    <url>/business-central/rest/runtime/org.jboss.qa.bpms:clustering:1.0.0.Final/history/instance/4/variable/count</url>
    <error>No runtime manager could be found for domain 'count'.</error>
</response>

I should mention that there are rows in the VariableInstanceLog table for this variable.

Very probably the problem is that org.kie.services.remote.rest.RuntimeResource uses the same @PathParam("id") for both deployment and variableId - take a look at the error msg: No runtime manager could be found for domain 'count'. 'count' is the name of the variable

tested with 6.0.0.CR1
Comment 1 Marco Rietveld 2013-08-09 07:09:10 EDT
Fixed, with this commit: 

https://github.com/droolsjbpm/droolsjbpm-integration/commit/5059e60c96d2d15af9dd30661e1120bf86c69c08

(Is ER1 the right target milestone? Or ER2?)
Comment 2 Radovan Synek 2013-09-04 08:08:12 EDT
Verified on BPMS 6.0.0.ER2

Note You need to log in before you can comment on or make changes to this bug.