Bug 990540 - Need to fix "dereferencing type-punned pointer will break strict-aliasing rules" during OCaml build
Need to fix "dereferencing type-punned pointer will break strict-aliasing rul...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ocaml (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Richard W.M. Jones
Martin Cermak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 08:29 EDT by Richard W.M. Jones
Modified: 2015-03-05 05:50 EST (History)
2 users (show)

See Also:
Fixed In Version: ocaml-4.01.0-22.1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-05 05:50:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2013-07-31 08:29:24 EDT
Description of problem:

The OCaml compiler build has a lot of errors like this:

freelist.c: In function 'caml_fl_reset':
freelist.c:364:3: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
   Next (Fl_head) = NULL;

These could indicate a build problem.

Version-Release number of selected component (if applicable):

ocaml-4.00.1-2.el7.x86_64

Additional info:

Here is a build log from Fedora, but the same errors appear
in the RHEL 7 build:

http://kojipkgs.fedoraproject.org//packages/ocaml/4.00.1/2.fc19/data/logs/x86_64/build.log
Comment 2 Richard W.M. Jones 2013-12-10 10:47:43 EST
Moving to RHEL 7.1 as this error has no apparent impact
on the OCaml compiler.
Comment 4 Richard W.M. Jones 2014-09-11 09:27:31 EDT
Needs QA ack before I can fix this.
Comment 7 errata-xmlrpc 2015-03-05 05:50:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0454.html

Note You need to log in before you can comment on or make changes to this bug.