Bug 990600 - Panel "Project Screen" is available only from pom.xml
Panel "Project Screen" is available only from pom.xml
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity medium
: ER5
: 6.0.0
Assigned To: Toni Rikkola
Sona Mala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 10:02 EDT by Sona Mala
Modified: 2014-08-06 16:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:17:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sona Mala 2013-07-31 10:02:24 EDT
Description of problem:
If you want to open the panel Project Screen then first you must open a pom.xml and activate it.

This is user unfriendly (how should user know, that he must switch to Technical view and then open just pom.xml)

Version-Release number of selected component (if applicable):
6.0.0 CR1

Expected results:
If you select "Tools/Project Editor" then shows a Project Screen for actual project in Project Explorer. Do not required pom.xml.

Additional info:
Comment 1 Sona Mala 2013-07-31 10:06:28 EDT
Exactly this happend after you clone a new repo.
Comment 2 manstis 2013-08-01 08:18:24 EDT
I experience the expected results; Tools->Project Editor shows the Project Editor for the active project (as selected in Project Explorer).

Please explain the issue a bit more.
Comment 3 Sona Mala 2013-08-02 03:57:30 EDT
Step to reproduce:
  1. clone new repository in Administration perspective
  2. go to Projects/Project Authoring perspective (depends on BRMS/BPMS)
  3. click on Tools dropdown menu


Actual result:
  All item are disabled to use. 
  Work around: go to any pom.xml and then go to Tools menu.
Comment 4 Toni Rikkola 2013-10-02 00:54:54 EDT
Can't reproduce, so looks like this bug is already fixed.
Comment 8 Sona Mala 2013-12-17 10:28:12 EST
Verified for ER5.

Note You need to log in before you can comment on or make changes to this bug.