Bug 990606 - rubygem-mongo dependency errors when updating from OSE 1.0 to 1.2
rubygem-mongo dependency errors when updating from OSE 1.0 to 1.2
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Kubernetes (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 10:19 EDT by Brenton Leanhardt
Modified: 2017-03-08 12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-04 09:30:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brenton Leanhardt 2013-07-31 10:19:30 EDT
Description of problem:

The versions of rubygem-mongo and rubygem-bson and rubygem-bson_ext are tightly coupled.

In 1.0 we shipped in Infra/Node:
rubygem-mongo-1.5.2-6.el6op.noarch
rubygem-bson-1.5.2-2.el6op.noarch
rubygem-bson_ext-1.5.2-2.el6op.x86_64

In 1.1 we shipped Infra/Node:
rubygem-mongo-1.8.3-1.el6op.noarch
rubygem-bson-1.8.3-1.el6op.noarch
rubygem-bson_ext-1.8.3-1.el6op.x86_64

In 1.2 we accidentally shipped in Infra (they are now only needed for Nodes):
rubygem-bson-1.8.3-1.el6op.noarch
rubygem-bson_ext-1.8.3-1.el6op.x86_64

Therefore if someone attempts to upgrade from 1.0 directly to 1.2 they will hit the following error message:

Error: Package: rubygem-mongo-1.5.2-6.el6op.noarch (@rhel-server-ose-infra-6-rpms)
           Requires: rubygem-bson = 1.5.2
           Removing: rubygem-bson-1.5.2-2.el6op.noarch (@rhel-server-ose-infra-6-rpms)
               rubygem-bson = 1.5.2-2.el6op
           Updated By: rubygem-bson-1.8.3-1.el6op.noarch (rhel-server-ose-1.2-infra-6-rpms)
               rubygem-bson = 1.8.3-1.el6op



After talking with Release Engineering they much preferred adding rubygem-mongo-1.8.3-1.el6op.noarch to the 1.2 channels instead of remove the unneeded rubygem-bson-1.8.3-1.el6op.noarch and rubygem-bson_ext-1.8.3-1.el6op.x86_64

No customers have reported this error but it would be best to perform this cleanup to avoid problems.  All that will be required is to test a 1.0 -> 1.2 upgrade and then ship an advisory that adds rubygem-mongo-1.5.2-6.el6op.noarch to the 1.2 Infra channel.
Comment 3 Gaoyun Pei 2013-08-26 05:39:50 EDT
Test this issue on puddle 1.2/2013-08-23

Broker and node could be installed successfully, rubygem-mongo-1.8.3-1.el6op could be found in Infra and Node repo, so move it to VERIFIED.

Note You need to log in before you can comment on or make changes to this bug.