Bug 990619 - Latest openjdk build introduces file conflict between i686 and x86_64
Latest openjdk build introduces file conflict between i686 and x86_64
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: java-1.7.0-openjdk (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Deepak Bhole
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 10:51 EDT by Andy Grimm
Modified: 2016-11-07 22:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 12:46:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Grimm 2013-07-31 10:51:29 EDT
Description of problem:

Two changes in the Fedora spec for java-1.7.0-openjdk introduced conflicts in the desktop files in the devel package:

http://pkgs.fedoraproject.org/cgit/java-1.7.0-openjdk.git/commit/?id=8a5396975f67ea715561d79e655afa4e39f32215
http://pkgs.fedoraproject.org/cgit/java-1.7.0-openjdk.git/commit/?id=58fb2545cb47a9021aa9e4c0dc0aa8dfd6c974ce

These changes were pulled into the latest RHEL 6 build, which means that the i686 and x86_64 packages can no longer coexist on a system.

Version-Release number of selected component (if applicable):

java-1.7.0-openjdk-1.7.0.25-2.4.1.0.el6

How reproducible:

Always

Steps to Reproduce:
1. get the latest packages from brew
2. yum install java-1.7.0-openjdk-1.7.0.25-2.4.1.0.el6.i686.rpm java-1.7.0-openjdk-devel-1.7.0.25-2.4.1.0.el6.i686.rpm java-1.7.0-openjdk-1.7.0.25-2.4.1.0.el6.x86_64.rpm java-1.7.0-openjdk-devel-1.7.0.25-2.4.1.0.el6.x86_64.rpm

Actual results:

The install fails due to file conflicts:

Transaction Check Error:
  file /usr/share/applications/java-1.7.0-openjdk-jconsole.desktop conflicts between attempted installs of java-1.7.0-openjdk-devel-1:1.7.0.25-2.4.1.0.el6.i686 and java-1.7.0-openjdk-devel-1:1.7.0.25-2.4.1.0.el6.x86_64
  file /usr/share/applications/java-1.7.0-openjdk-policytool.desktop conflicts between attempted installs of java-1.7.0-openjdk-devel-1:1.7.0.25-2.4.1.0.el6.i686 and java-1.7.0-openjdk-devel-1:1.7.0.25-2.4.1.0.el6.x86_64


Expected results:

In prior versions, it was possible to install both arches of java-1.7.0-openjdk-devel side-by-side, so this should still work.
Comment 3 Deepak Bhole 2013-07-31 12:46:35 EDT
Closing as NOTABUG since multi-lib is not supported.

Note You need to log in before you can comment on or make changes to this bug.