Bug 990620 - ResourceException: IJ000459: Transaction is not active is thrown clicking on Tasks List and on starting a task
ResourceException: IJ000459: Transaction is not active is thrown clicking on ...
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ER2
: 6.0.0
Assigned To: Maciej Swiderski
Jiri Svitak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 10:52 EDT by Jiri Svitak
Modified: 2015-06-01 21:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:11:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (59.60 KB, text/plain)
2013-07-31 10:52 EDT, Jiri Svitak
no flags Details

  None (edit)
Description Jiri Svitak 2013-07-31 10:52:04 EDT
Created attachment 781189 [details]
server.log

ResourceException: IJ000459: Transaction is not active is thrown clicking on Tasks List and on starting a task. See the whole attached server.log.

16:30:52,232 ERROR [stderr] (http-localhost/127.0.0.1:8080-4) Caused by: javax.resource.ResourceException: IJ000459: Transaction is not active: tx=TransactionImple < ac, BasicAction: 0:ffff0a221e05:5eb07097:51f91842:1a5 status: ActionStatus.ABORT_ONLY >
This is thrown by clicking on Tasks List.

16:36:09,966 ERROR [stderr] (http-localhost/127.0.0.1:8080-2) Caused by: javax.resource.ResourceException: IJ000459: Transaction is not active: tx=TransactionImple < ac, BasicAction: 0:ffff0a221e05:5eb07097:51f91842:1e0 status: ActionStatus.ABORT_ONLY >
This is thrown by clicking on a start task button.

How to reproduce:
1.) Install jBPM 6 CR1 into EAP 6.1
2.) Add user guest to eap6 config files:
guest=b5d048a237bfd2874b6928e1f37ee15e   # guest/guest
guest=guest,kie-user,ADMIN
3.) clone git repository from
https://code.engineering.redhat.com/gerrit/p/bpms-assets.git
4.) build a deploy project bpms-perf
5.) start process HumanTask (it's a simple custom process Start->HT->End, actor is guest)

This bug does not seem to affect functionality, the task is completed (tries only with empty task data) and also the process is completed. However such exceptions should not be thrown if everything is ok, or there's a risk that such exception can be source of problems later.

My environment:
JBoss EAP 6.1
jBPM 6 CR1
H2 db
Comment 1 Jiri Svitak 2013-08-01 06:42:56 EDT
To clone the bpms-assets repository use read-only mirror:
git clone git://git.app.eng.bos.redhat.com/bpms-assets.git
Comment 2 Maciej Swiderski 2013-08-02 08:01:54 EDT
the cause of this issue was due to user and group has exactly same id (guest/guest)and that is not allowed as they are kept inside same table. Although the cause is clear the actual exception was swallowed which allowed to make the next operation inline (query) which in turn failed as the insert of group marked transaction as rollback only.
Change was applied to ensure that the exception is propagated up to the caller with actual cause.

Ensuring that user and groups are unique resolves the issue completely.

Commit on 6.0.x branch:
https://github.com/droolsjbpm/jbpm/commit/e8790f77c9bbab986c2f6e952ba3e47ff4289489
Comment 3 Jiri Svitak 2013-08-29 08:35:18 EDT
When the same name is used for user name and group, a proper exception is thrown.

Verified in BPMS 6 ER2 (redhat-2).

Note You need to log in before you can comment on or make changes to this bug.