Bug 990676 - allinone install fails | Error during puppet run : Error: Could not find or load main class org.jruby.Main
allinone install fails | Error during puppet run : Error: Could not find or ...
Status: CLOSED NOTABUG
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: RHOS Maint
Nir Magnezi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 13:46 EDT by Mark
Modified: 2013-09-20 06:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-20 06:36:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2013-07-31 13:46:13 EDT
Description of problem:


All in one isntall fails from following directions @ http://openstack.redhat.com/Quickstart

Version-Release number of selected component (if applicable):

using either grizzly or havana. 

How reproducible:
every time on F19

Steps to Reproduce:
1. follow the quick start guide
2. enable grizzly or havana RDP repo. 
3. sudo yum install -y openstack-packstack
4. sudo packstack --allinone --os-quantum-install=n

Actual results:

2013-07-31 11:18:52::INFO::run_setup::399::root:: A new answerfile was created in: /root/packstack-answers-20130731-111852.txt
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'yes', and match: 'yes'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'yes', and match: 'yes'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'yes', and match: 'yes'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'y', and match: 'y'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'yes', and match: 'yes'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'y', and match: 'y'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'y', and match: 'y'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'True', and match: 'True'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'y', and match: 'y'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'True', and match: 'True'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'n', and match: 'y'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'False', and match: 'True'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'False', and match: 'True'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'y', and match: 'y'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'y', and match: 'y'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'n', and match: 'y'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'y', and match: 'y'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'yes', and match: 'yes'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'y', and match: 'y'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'yes', and match: 'yes'
2013-07-31 11:18:53::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'yes', and match: 'yes'
2013-07-31 11:18:57::ERROR::shell::83::root:: ============= STDERR ==========
2013-07-31 11:18:57::ERROR::shell::85::root:: Warning: Permanently added '10.0.2.15' (RSA) to the list of known hosts.
+ trap t ERR
+ vgdisplay cinder-volumes
  Volume group "cinder-volumes" not found
++ t
++ exit 5

2013-07-31 11:18:57::INFO::cinder_250::191::root:: A new cinder volumes group will be created
2013-07-31 11:19:46::ERROR::ospluginutils::143::root:: Error  during remote puppet apply of /var/tmp/packstack/20130731-111852-ebggmg/manifests/10.0.2.15_prescript.pp
2013-07-31 11:19:46::ERROR::ospluginutils::144::root:: Error: Could not find or load main class org.jruby.Main

2013-07-31 11:19:46::ERROR::run_setup::889::root:: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 870, in main
    single_step_aio_install(options)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 658, in single_step_aio_install
    single_step_install(options)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 688, in single_step_install
    _main(answerfilepath)
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 577, in _main
    runSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/run_setup.py", line 554, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.7/site-packages/packstack/installer/setup_controller.py", line 90, in runAllSequences
    sequence.run(self.CONF)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 105, in run
    step.run(config=config)
  File "/usr/lib/python2.7/site-packages/packstack/installer/core/sequences.py", line 52, in run
    raise SequenceError(str(ex))
SequenceError: Error during puppet run : Error: Could not find or load main class org.jruby.Main

2013-07-31 11:19:46::INFO::run_setup::598::root:: Removing /var/tmp/packstack/69fb13150de84738bdace8ec5d902f98 on 10.0.2.15 (if it is a remote host)
2013-07-31 11:19:46::INFO::run_setup::532::root::  * A new answerfile was created in: /root/packstack-answers-20130731-111852.txt
2013-07-31 11:19:46::INFO::run_setup::532::root::  * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
2013-07-31 11:19:46::INFO::run_setup::532::root::  * To use the command line tools you need to source the file /root/keystonerc_admin created on 10.0.2.15
2013-07-31 11:19:46::INFO::run_setup::532::root::  * To use the console, browse to http://10.0.2.15/dashboard
2013-07-31 11:19:46::INFO::run_setup::532::root::  * To use Nagios, browse to http://10.0.2.15/nagios username : nagiosadmin, password : e0ffd94791dd44a3



Expected results:

dash board and nagios should be up, 

Additional info:
running f19 in a Vbox VM.
Comment 1 Martin Magr 2013-09-20 06:36:21 EDT
This was cause because puppet package was installing jruby instead of ruby. This should be fixed in recent puppet package.

Note You need to log in before you can comment on or make changes to this bug.