This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 990680 - when tboot is installed it automatically takes over as kernel of choice
when tboot is installed it automatically takes over as kernel of choice
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tboot (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Tony Camuso
Release Test Team
:
Depends On:
Blocks: 1002711
  Show dependency treegraph
 
Reported: 2013-07-31 14:12 EDT by Dave Sullivan
Modified: 2015-09-18 09:54 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-18 09:54:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Sullivan 2013-07-31 14:12:13 EDT
Description of problem:

when tboot is installed it automatically takes over as kernel of choice

Version-Release number of selected component (if applicable):

6.4

How reproducible:

You can install tboot from kickstart

%packages
@Base
+tboot 

or install from using --optional

%packages
@Base --optional

After a fresh install including optional for @base, tboot is enabled by default.
~~~
# sed -n '/%packages/,/%end/p' /root/anaconda-ks.cfg 
%packages
@Base --optional
@Core
-NetworkManager

%end

# rpm -q tboot
tboot-1.7.0-4.el6.x86_64

# grep -v ^# /boot/grub/grub.conf 
default=0
timeout=5
serial --unit=0 --speed=115200
terminal --timeout=5 serial console
title Red Hat Enterprise Linux (2.6.32-358.el6.x86_64)
	root (hd0,0)
	kernel /tboot.gz logging=vga,serial,memory
	module /vmlinuz-2.6.32-358.el6.x86_64 ro root=/dev/mapper/vg00-root intel_iommu=on rd_NO_LUKS  KEYBOARDTYPE=pc KEYTABLE=us rd_LVM_LV=vg00/swap LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 rd_LVM_LV=vg00/root crashkernel=auto crashkernel=auto console=ttyS0,115200 rd_NO_DM
	module /initramfs-2.6.32-358.el6.x86_64.img
~~~

Actual results:

So we get forced into a tboot boot.

Expected results:

tboot shouldn't be the default if it installed, it's ok to set up grub with a tboot kernel but it should default to the normal line

Additional info:

As this is only kernel, grubby won't let you remove it
~~~
# grubby --remove-kernel=/boot/tboot.gz 
grubby fatal error: unable to find a suitable template
grubby: doing this would leave no kernel entries. Not writing out new config.
~~~


So add kernel with grubby then remove tboot kernel (missing root(hd0,0) line but works in my test).  May be best to test the new kernel line with reboot before removing (as recovery with both options still in grub.conf is easier).
~~~
# ARGS=$(grep "^[[:space:]]*module /vmlinuz-$(uname -r)" /boot/grub/grub.conf | sed -e 's/^.*x86_64 //' | head -n 1)

# grubby --add-kernel=/boot/vmlinuz-$(uname -r) --args="${ARGS}" --initrd=/boot/initramfs-$(uname -r).img --make-default --title "Red Hat Enterprise Linux without tboot ($(uname -r))"

# grep -v ^# /boot/grub/grub.conf 
default=0
timeout=5
serial --unit=0 --speed=115200
terminal --timeout=5 serial console
title Red Hat Enterprise Linux without tboot (2.6.32-358.el6.x86_64
	kernel /vmlinuz-2.6.32-358.el6.x86_64 ro root=/dev/mapper/vg00-root intel_iommu=on rd_NO_LUKS KEYBOARDTYPE=pc KEYTABLE=us rd_LVM_LV=vg00/swap LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 rd_LVM_LV=vg00/root crashkernel=auto crashkernel=auto console=ttyS0,115200 rd_NO_DM
	initrd /initramfs-2.6.32-358.el6.x86_64.img
title Red Hat Enterprise Linux (2.6.32-358.el6.x86_64)
	root (hd0,0)
	kernel /tboot.gz logging=vga,serial,memory
	module /vmlinuz-2.6.32-358.el6.x86_64 ro root=/dev/mapper/vg00-root intel_iommu=on rd_NO_LUKS  KEYBOARDTYPE=pc KEYTABLE=us rd_LVM_LV=vg00/swap LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 rd_LVM_LV=vg00/root crashkernel=auto crashkernel=auto console=ttyS0,115200 rd_NO_DM
	module /initramfs-2.6.32-358.el6.x86_64.img




# grubby --remove-kernel=/boot/tboot.gz

# grep -v ^# /boot/grub/grub.conf 
default=0
timeout=5
serial --unit=0 --speed=115200
terminal --timeout=5 serial console
title Red Hat Enterprise Linux without tboot (2.6.32-358.el6.x86_64
	kernel /vmlinuz-2.6.32-358.el6.x86_64 ro root=/dev/mapper/vg00-root intel_iommu=on rd_NO_LUKS KEYBOARDTYPE=pc KEYTABLE=us rd_LVM_LV=vg00/swap LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 rd_LVM_LV=vg00/root crashkernel=auto crashkernel=auto console=ttyS0,115200 rd_NO_DM
	initrd /initramfs-2.6.32-358.el6.x86_64.img
~~~


Now can remove tboot, as not in use by grub.
~~~
# yum -y erase tboot
~~~
Comment 4 RHEL Product and Program Management 2013-10-13 22:53:56 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 Vincent S. Cojot 2014-01-13 17:15:07 EST
Hello,
What if I'd like to keep 'tboot' installed but keep my default kernel?
I had tboot installed and somehow (investigation going on) the /etc/sysconfig/kernel got modified to point to tboot.

Since tboot drops some arguments from the kernel grub.conf, upon the next errata kernel update the system rebooted and lost its network (it was missing biosdevname=0, amongst others).

I don't mind keeping the 'tboot' rpm but I don't want it to take actions or make itself the default without my agreement. :)

Vincent
Comment 8 Chris Williams 2015-09-18 09:54:20 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 6 and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.