Bug 99071 - Gnu __typeof__ extension to g++ throws internal compiler error
Gnu __typeof__ extension to g++ throws internal compiler error
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
: 106564 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-13 18:47 EDT by Timothy Wesson
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 20:10:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Source file that generates compiler error (21.06 KB, text/plain)
2003-07-13 18:52 EDT, Timothy Wesson
no flags Details

  None (edit)
Description Timothy Wesson 2003-07-13 18:47:42 EDT
Description of problem:
Gnu typeof entension used to create polymorphic return types causes the compiler
to baulk

Version-Release number of selected component (if applicable):
gcc (GCC) 3.2 20020903 (Red Hat Linux 8.0 3.2-7)

How reproducible:
Compile attached file.

Steps to Reproduce:
1. Compile attached file thus:
   g++ -g -Wall matrix.cpp
2.
3.
    
Actual results:
matrix.cpp: In function `int main()':
matrix.cpp:723: Internal compiler error in write_type, at cp/mangle.c:1458

Expected results:
Silent compile, generating a.out

Additional info:
The file throws the same error under DOS, running gxx (gcc version 2.23), but
said machine is not available from home, where I now am.
Comment 1 Timothy Wesson 2003-07-13 18:52:45 EDT
Created attachment 92901 [details]
Source file that generates compiler error

Source file that generates compiler error when compiled with g++;
"g++ matrix.cpp" is sufficient to generate the error.
Comment 2 Jakub Jelinek 2003-07-18 11:03:38 EDT
http://gcc.gnu.org/PR11578
Comment 3 Richard Henderson 2004-10-03 20:10:59 EDT
Still fails in gcc 4.0.  There is sporadic activity on the gcc PR.
Comment 4 Richard Henderson 2004-10-04 00:34:42 EDT
*** Bug 106564 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.