Bug 990751 - The position of the "Done" button on Anaconda screens is inconsistent
The position of the "Done" button on Anaconda screens is inconsistent
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 1098230 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-31 18:15 EDT by Dale R. Worley
Modified: 2014-05-15 10:19 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-16 17:12:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dale R. Worley 2013-07-31 18:15:34 EDT
Description of problem:
The position of the "Done" button (or its equivalent) on Anaconda screens is inconsistent.  On some screens, it is in the lower-right corner (which is expected).  On some screens, it is in the upper-left corner (which is generally not conventional for web pages.)  This is not a major problem, bit it does make Anaconda more confusing and awkward to use than it could be.

Version-Release number of selected component (if applicable):
19.30.13-1
Comment 1 Steve Tyler 2013-08-01 00:01:09 EDT
Could you link to a web page that has a "Done" button?
Comment 2 Steve Tyler 2013-08-01 00:18:17 EDT
Each of the installer screens has a title -- could you identify two that have inconsistent "Done" button positions?
Comment 3 Dale R. Worley 2013-08-01 15:09:07 EDT
(In reply to Steve Tyler from comment #1)
> Could you link to a web page that has a "Done" button?

Data entry forms that have a "Done" or "Go" type button at the bottom of the data entry fields:

In the Installer "Manual Partitioning" screen, once a mount point/partition has been selected, within the right-hand side (data entry area), the "Update settings" button is to the lower-right of the data fields.

The "Additional comments" entry section at the bottom of https://bugzilla.redhat.com/show_bug.cgi?id=990751 (This may require you to be logged in to Bugzilla.)

https://bugzilla.redhat.com/query.cgi (That has a "Search" button at the upper-right, to the right of the first row of fields, but it also has a "Search" button at the lower-left of the fields.)

http://www.boxoh.com/

http://www.flytecomm.com/trackflight (The data entry area has three separate forms, each of which has a "go" button at the bottom and more-or-less to the right.)

http://www.measuringworth.com/m/calculators/uscompare/

http://matrix.itasoftware.com/

https://tools.usps.com/go/ZipLookupAction!input.action
Comment 4 Dale R. Worley 2013-08-01 15:13:28 EDT
(In reply to Steve Tyler from comment #2)
> Each of the installer screens has a title -- could you identify two that
> have inconsistent "Done" button positions?

title "Welcome to Fedora 19" subtitle "What language ..."
button in lower-left corner: "Quit"
button in lower-right corner: "Continue"

title "Network Configuration"
button in lower-right corner: "Continue"

title "Installation Summary"
button in lower-right corner: "Begin Installation"

title "Installation Sources"
button in upper-left corner: "Done"

title "Date & Time"
button in upper-left corner: "Done"

title "Language Support"
button in upper-left corner: "Done"

title "Keyboard Layout"
button in upper-left corner: "Done"

title "Software Selection"
button in upper-left corner: "Done"

title "Network Configuration"
button in upper-left corner: "Done"

title "Installation Destination"
button in upper-left corner: "Done"

title "Manual Partitioning"
button in upper-left corner: "Done"
button in lower-right corner: "Reset All"
Comment 5 Steve Tyler 2013-08-01 21:35:47 EDT
(In reply to Dale R. Worley from comment #3)
> (In reply to Steve Tyler from comment #1)
> > Could you link to a web page that has a "Done" button?
> 
> Data entry forms that have a "Done" or "Go" type button at the bottom of the
> data entry fields:
> 
> In the Installer "Manual Partitioning" screen, once a mount point/partition
> has been selected, within the right-hand side (data entry area), the "Update
> settings" button is to the lower-right of the data fields.

Confirmed: "Update Settings" button.

> The "Additional comments" entry section at the bottom of
> https://bugzilla.redhat.com/show_bug.cgi?id=990751 (This may require you to
> be logged in to Bugzilla.)

There are two "Save Changes" buttons, one at the top, one at the bottom. They do the same thing, however.

> https://bugzilla.redhat.com/query.cgi (That has a "Search" button at the
> upper-right, to the right of the first row of fields, but it also has a
> "Search" button at the lower-left of the fields.)

There is a row of tabs. They have varying numbers of search buttons:
Simple Search -- Advanced Search -- Google Search
Search(1)        Search(2)          Google Search(1)

> http://www.boxoh.com/

"Track" button.

> http://www.flytecomm.com/trackflight (The data entry area has three separate
> forms, each of which has a "go" button at the bottom and more-or-less to the
> right.)

Confirmed: three "go" buttons. (and misrendering in Firefox ...)

> http://www.measuringworth.com/m/calculators/uscompare/

"Calculate" button.

> http://matrix.itasoftware.com/

"Search" button.

> https://tools.usps.com/go/ZipLookupAction!input.action

"Find" button.
Comment 6 Steve Tyler 2013-08-01 21:57:41 EDT
(In reply to Steve Tyler from comment #5)
> (In reply to Dale R. Worley from comment #3)
> > (In reply to Steve Tyler from comment #1)
> > > Could you link to a web page that has a "Done" button?
> > 
> > Data entry forms that have a "Done" or "Go" type button at the bottom of the
> > data entry fields:
...

All the examples you provided are "Command" buttons, that initiate a process or calculation:
http://msdn.microsoft.com/en-us/library/windows/desktop/aa511453.aspx

The "Done" and "Continue" buttons in the installer are navigation buttons -- they are used to move from one dialog to another.

Microsoft calls them "Links", and they do not use a button graphic:
http://msdn.microsoft.com/en-us/library/windows/desktop/aa511483.aspx

Not distinguishing the two in the installer is a GUI design bug, IMO.

The overall structure of the dialogs is called a hub and spoke design in contrast with a linear design. Diagrams and discussion here:

Anaconda/NewInstaller
https://fedoraproject.org/wiki/Anaconda/NewInstaller
Comment 7 Steve Tyler 2013-08-01 22:04:13 EDT
(In reply to Steve Tyler from comment #6)
...
> Not distinguishing the two in the installer is a GUI design bug, IMO.
...

In fact, your list in Comment 4 shows both Command and Link buttons:

"Begin Installation" and "Reset All" are Command buttons.

"Begin Installation" is also a Link button, because it takes you to another dialog, in which you can configure root and user accounts. So it is a hybrid.
Comment 8 Dale R. Worley 2013-08-02 10:55:58 EDT
> > https://bugzilla.redhat.com/query.cgi (That has a "Search" button at the
> > upper-right, to the right of the first row of fields, but it also has a
> > "Search" button at the lower-left of the fields.)
> 
> There is a row of tabs. They have varying numbers of search buttons:
> Simple Search -- Advanced Search -- Google Search
> Search(1)        Search(2)          Google Search(1)

I forgot to mention that (because I was looking at a window I'd opened a while previously).  I was specifically referring to the "Advanced Search" tab.
Comment 9 Chris Lumens 2013-10-16 17:12:35 EDT
Spokes that are standalone (that is, not reached via a hub but are off on their own like the welcome spoke) have the done button on the bottom right.  Hubs have this too.  This is because you are moving in a line through these UI elements.  Spokes that are reached via a hub have the done button on the top left.  This is because you are moving back to the hub - not linearly.  This has been discussed on mailing lists in the past, I do believe.
Comment 10 David Shea 2014-05-15 10:19:01 EDT
*** Bug 1098230 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.