Bug 990788 - authconfig cause service rpcbind restart, and registered rpc server lost.
authconfig cause service rpcbind restart, and registered rpc server lost.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: authconfig (Show other bugs)
7.0
All Linux
unspecified Severity urgent
: rc
: 7.0
Assigned To: Tomas Mraz
David Spurek
: Reopened, TestBlocker
Depends On:
Blocks: 990790
  Show dependency treegraph
 
Reported: 2013-07-31 22:58 EDT by Yin.JianHong
Modified: 2015-03-02 00:27 EST (History)
4 users (show)

See Also:
Fixed In Version: authconfig-6.2.6-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 990790 (view as bug list)
Environment:
Last Closed: 2014-06-13 06:59:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yin.JianHong 2013-07-31 22:58:37 EDT
Description of problem:
authconfig cause service rpcbind restart, and registered rpc server lost.

Version-Release number of selected component (if applicable):
authconfig-6.2.6-3.el7

How reproducible:
100%

Steps to Reproduce:
1. service rpcbind start
2. service nfs start
3. authconfig --updateall --enablenis --nisdomain=$nisDomain --nisserver=$nisServ

Actual results:
rpcbind's PID change
rpcinfo -s show nfs server not register

Expected results:
rpcbind's PID not change
rpcinfo -s show nfs server register

Additional info:
  same test in RHEL5 is OK
Comment 1 Peter Vrabec 2013-08-01 11:30:28 EDT
What are the reasons for this bug being a "TestBlocker" please?
Comment 2 Yin.JianHong 2013-08-01 20:20:21 EDT
(In reply to Peter Vrabec from comment #1)
> What are the reasons for this bug being a "TestBlocker" please?

It cause our some nfs test(with nis) case run fail.
I can debug and change the case code to avoid. However, this increases our workload.
Comment 3 Tomas Mraz 2013-08-05 04:21:19 EDT
I am sorry but this is not a real bug. You can either call the authconfig with --nostart option if you do not want it to restart the services or you can restart the nfs after authconfig.
Comment 4 Yin.JianHong 2013-08-05 04:47:00 EDT
(In reply to Tomas Mraz from comment #3)
> I am sorry but this is not a real bug. You can either call the authconfig
> with --nostart option if you do not want it to restart the services or you
> can restart the nfs after authconfig.

I do not think that.

1. First. In RHEL5 it work fine: just start nis bind, not restart the rpcbind server.

2. what do you think about if you start a server based rpc, then you find that
   all other server registered in rpcbind can not work.
   Obviously, that's wrong.
Comment 5 Tomas Mraz 2013-08-05 10:42:58 EDT
OK, that makes sense, we can change authconfig to start the rpcbind and never stop it. Although in RHEL-5 authconfig restarts portmapper which is probably a problem as well.
Comment 6 Yin.JianHong 2013-08-05 22:33:21 EDT
(In reply to Tomas Mraz from comment #5)
> OK, that makes sense, we can change authconfig to start the rpcbind and
> never stop it. Although in RHEL-5 authconfig restarts portmapper which is
> probably a problem as well.

ok, thanks;
BTW: I test in RHEL-5.9, authconfig just start the ypbind, not restart portmapper;
     so maybe the action of restart rpcbind/portmapper is introduced at RHEL6+ ,,
Comment 8 Ludek Smid 2014-06-13 06:59:17 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.