Bug 99080 - Default installation of sendmail can't send mail: no route to host
Summary: Default installation of sendmail can't send mail: no route to host
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-14 09:46 UTC by Jim
Modified: 2007-04-18 16:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-30 21:37:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jim 2003-07-14 09:46:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030529

Description of problem:
After installing redhat 9, I am unable to send mail. Using eg.
  mail -s "test mail" bob@redhat.com
will result in the mail sitting in the queue with the message "no route to
host". This would initially seem like a DNS issue, however dig can get all the
information on any domain, including MX information. Any website is browsable. 

I have tried this on three separate, successive installations of RedHat 9. The
security settings are medium, and SMTP is allowed. 

I have tried uninstalling sendmail and re-installing

I have tried altering the following sendmail settings
  - SMART_HOST
  - Masquerade
by editing sendmail.mc and running m4 to generate a new configuration.

I have tried sending mail from pine, first altering the configuration so that it
sends via my ISP's SMTP server. This also fails.

Other computers on the same network segment can send mail, so the ISP is not
blocking port 25.


Version-Release number of selected component (if applicable):
8.12.8-5.90

How reproducible:
Always

Steps to Reproduce:
1. Install redhat 
2. Try to send mail

    

Actual Results:  mail is not sent

Additional info:

I can't imagine this is a widespread bug, or else everyone would have complained
about it. I think it must therefore be something specific to my configuration,
although I can't think what.

Comment 1 Jim 2003-07-15 05:09:24 UTC
OK, I think I've figured it out. Its to do with the way sendmail treats hostnames.

When you install RH9, it asks you for a hostname which the installer writes into 
/etc/sysconfig/network
and
/etc/hosts

The entry into /etc/hosts seems to confuse sendmail. Removing the entry
containing the hostname allows sendmail to work. 
Eg.
If you called your machine rh9box on install, you'll have the following in your
/etc/hosts file

127.0.0.1         rh9box localhost.localdomain localhost

This should read
127.0.0.1         localhost

for sendmail to work. Now the question is does anything else break when you
change it?


 

Comment 2 Florian La Roche 2003-07-30 21:37:51 UTC
Looks like a config problem, closing bug.

Florian La Roche


Comment 3 Jim 2003-07-30 21:44:32 UTC
Of course its a config problem. My point was that it was a config problem
introduced by the Redhat Installer. i.e. the installer disables sendmail's
ability to send mail. Which kind of negates its purpose. Anyway, I've done my
duty reporting it. 


Note You need to log in before you can comment on or make changes to this bug.