Bug 990849 - The version of 10gen-mms-agent becomes 0.2
The version of 10gen-mms-agent becomes 0.2
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 02:10 EDT by Zhe Wang
Modified: 2015-05-14 19:25 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 18:58:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zhe Wang 2013-08-01 02:10:27 EDT
Description of problem:
The version of 10gen-mms-agent is 0.2 (10gen-mms-agent-0.2), instead of 10gen-mms-agent-0.1 when showing the cartridge list. Moreover, 10gen-mms-agent-0.2 cartridge works properly. 

This problem exists in devenv-stage_429 only, but not INT(devenv_3595) in which the version is still 0.1. It would be better to keep the consistency if there is known user story about this change.

Version-Release number of selected component (if applicable):
devenv-stage_429

How reproducible:
always

Steps to Reproduce:
1. show the list of all cartridges via RHC
2. create an app with mongodb-2.2 added
3. register an account from http://mms.10gen.com,get api key and secret key from setting page
4. add 10gen-mms-agent-0.2 cartridge with the settings.py file obtained in Step 3
5. check if the mms-agent cartridge functions as expected in the guide https://www.openshift.com/blogs/getting-started-with-mongo-monitoring-service-mms-on-openshift

Actual results:
In Step 1, only 10gen-mms-agent-0.2 was displayed in the cartridge list.

[zhe@fedora run106]$ rhc cartridge list
jbossas-7           JBoss Application Server 7                web
jbosseap-6.0 (*)    JBoss Enterprise Application Platform 6.0 web
jenkins-1.4         Jenkins Server 1.4                        web
nodejs-0.6          Node.js 0.6                               web
perl-5.10           Perl 5.10                                 web
php-5.3             PHP 5.3                                   web
python-2.6          Python 2.6                                web
python-2.7          Python 2.7                                web
python-3.3          Python 3.3                                web
ruby-1.8            Ruby 1.8                                  web
ruby-1.9            Ruby 1.9                                  web
jbossews-1.0        Tomcat 6 (JBoss EWS 1.0)                  web
jbossews-2.0        Tomcat 7 (JBoss EWS 2.0)                  web
zend-5.6            Zend Server 5.6                           web
diy-0.1             Do-It-Yourself 0.1                        web
10gen-mms-agent-0.2 10gen Mongo Monitoring Service Agent      addon
cron-1.4            Cron 1.4                                  addon
jenkins-client-1.4  Jenkins Client 1.4                        addon
mongodb-2.2         MongoDB NoSQL Database 2.2                addon
mysql-5.1           MySQL Database 5.1                        addon
metrics-0.1         OpenShift Metrics 0.1                     addon
haproxy-1.4         OpenShift Web Balancer                    addon
phpmyadmin-3.4      phpMyAdmin 3.4                            addon
postgresql-8.4      PostgreSQL Database 8.4                   addon
postgresql-9.2      PostgreSQL Database 9.2                   addon
rockmongo-1.1       RockMongo 1.1                             addon
switchyard-0.6      SwitchYard 0.6                            addon

Moreover, after adding the 10gen-mms-agent-0.2 cartridge, it worked properly as expected.

Expected results:
The version of 10gen-mms-agent cartridge should be consistent in 0.1 if there are no major updates about it.

Additional info:
Comment 1 Zhe Wang 2013-08-01 02:13:50 EDT
Looks like the problem could be caused by this commit of changing cartridge versions in stage branch:

https://github.com/openshift/origin-server/commit/f1a400cc2e3890aa2003becc3685ec5fd8c3e8d4
Comment 2 openshift-github-bot 2013-08-01 11:21:45 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/0b186a57e18374814f6dc2a9a6ad513a0bf768b1
Bug 990849 - Bumped manifest Version element in error

* Bumped 10gen-mms-agent manifest Version number in place of Cartridge-Version
Comment 3 Zhe Wang 2013-08-01 21:49:56 EDT
Verified in STG(devenv-stage_435), and the cartridge list is:

jbossas-7           JBoss Application Server 7                web
jbosseap-6.0 (*)    JBoss Enterprise Application Platform 6.0 web
jenkins-1.4         Jenkins Server 1.4                        web
nodejs-0.6          Node.js 0.6                               web
perl-5.10           Perl 5.10                                 web
php-5.3             PHP 5.3                                   web
python-2.6          Python 2.6                                web
python-2.7          Python 2.7                                web
python-3.3          Python 3.3                                web
ruby-1.8            Ruby 1.8                                  web
ruby-1.9            Ruby 1.9                                  web
jbossews-1.0        Tomcat 6 (JBoss EWS 1.0)                  web
jbossews-2.0        Tomcat 7 (JBoss EWS 2.0)                  web
zend-5.6            Zend Server 5.6                           web
diy-0.1             Do-It-Yourself 0.1                        web
10gen-mms-agent-0.1 10gen Mongo Monitoring Service Agent      addon
cron-1.4            Cron 1.4                                  addon
jenkins-client-1.4  Jenkins Client 1.4                        addon
mongodb-2.2         MongoDB NoSQL Database 2.2                addon
mysql-5.1           MySQL Database 5.1                        addon
metrics-0.1         OpenShift Metrics 0.1                     addon
haproxy-1.4         OpenShift Web Balancer                    addon
phpmyadmin-3.4      phpMyAdmin 3.4                            addon
postgresql-8.4      PostgreSQL Database 8.4                   addon
postgresql-9.2      PostgreSQL Database 9.2                   addon
rockmongo-1.1       RockMongo 1.1                             addon
switchyard-0.6      SwitchYard 0.6                            addon

Note You need to log in before you can comment on or make changes to this bug.