Bug 990887 - nfs: crash in update 5 bits
nfs: crash in update 5 bits
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: rjoseph
: Reopened
Depends On: 969372
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 03:17 EDT by rjoseph
Modified: 2014-04-17 07:45 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 969372
Environment:
Last Closed: 2014-04-17 07:45:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-08-01 03:38:44 EDT
REVIEW: http://review.gluster.org/5452 (nfs: crash in update 5 bits) posted (#1) for review on master by Rajesh Joseph (rjoseph@redhat.com)
Comment 2 Anand Avati 2013-08-01 04:16:55 EDT
REVIEW: http://review.gluster.org/5452 (nfs: Fix for NFS crash during blocking NLM call.) posted (#2) for review on master by Rajesh Joseph (rjoseph@redhat.com)
Comment 3 Anand Avati 2013-08-01 12:54:32 EDT
COMMIT: http://review.gluster.org/5452 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 6235e8e956ce6d72c88ddb3ad81c0842ee4d089c
Author: Rajesh Joseph <rjoseph@redhat.com>
Date:   Thu Aug 1 12:55:51 2013 +0530

    nfs: Fix for NFS crash during blocking NLM call.
    
    Bug 990887: During a blocking NLM call NFS server is crashing.
    
    Cause: When nlm4_establish_callback function is called from nlm4svc_send_granted the cs->req->trans
    pointer is NULL. Thus using this pointer will result in a crash. Whereas cs->trans points to a
    valid transport object. NLM should use cs->trans instead of cs->req->trans.
    
    Fix: Replaced cs->req->trans with cs->trans.
    
    Change-Id: I425e48e0aafc9a6c130912edf2e801d8c4c9472d
    BUG: 990887
    Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-on: http://review.gluster.org/5452
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 4 Anand Avati 2014-04-14 16:24:29 EDT
REVIEW: http://review.gluster.org/7478 (nfs: Fix for NFS crash during blocking NLM call.) posted (#1) for review on release-3.4 by Justin Clift (justin@gluster.org)
Comment 5 Anand Avati 2014-04-14 16:56:58 EDT
COMMIT: http://review.gluster.org/7478 committed in release-3.4 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit c1c7ae92a2b6bb7d57270fadd7a5d61c90fa3781
Author: Rajesh Joseph <rjoseph@redhat.com>
Date:   Thu Aug 1 12:55:51 2013 +0530

    nfs: Fix for NFS crash during blocking NLM call.
    
    Bug 990887: During a blocking NLM call NFS server is crashing.
    
    Cause: When nlm4_establish_callback function is called from nlm4svc_send_granted the cs->req->trans
    pointer is NULL. Thus using this pointer will result in a crash. Whereas cs->trans points to a
    valid transport object. NLM should use cs->trans instead of cs->req->trans.
    
    Fix: Replaced cs->req->trans with cs->trans.
    
    Backport of: http://review.gluster.org/#/c/5452/
    
    BUG: 990887
    Change-Id: I33d4b6634752333d6791b1a47ebf10c787c22120
    Signed-off-by: Justin Clift <justin@gluster.org>
    Reviewed-on: http://review.gluster.org/7478
    Reviewed-by: Harshavardhana <harsha@harshavardhana.net>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 6 Niels de Vos 2014-04-17 07:45:07 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.