Bug 990966 - [virtio-win][scsi]Disk can not format after disk shinking
[virtio-win][scsi]Disk can not format after disk shinking
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
x86_64 Windows
high Severity high
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 06:04 EDT by Mike Cao
Modified: 2015-11-22 22:37 EST (History)
7 users (show)

See Also:
Fixed In Version: virtio-win-prewhql-0.1-70
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-01 11:35:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Cao 2013-08-01 06:04:47 EDT
Description of problem:


Version-Release number of selected component (if applicable):
2.6.32-401.el6.x86_64
package qemu-kvm-rhev is not installed
seabios-0.6.1.2-26.el6.x86_64
qemu-kvm-0.12.1.2-2.382.el6.x86_64
package sgabios is not installed
spice-server-0.12.4-2.el6.x86_64
virtio-win-prwehql-66


How reproducible:
100%

Steps to Reproduce:
1.Format 5GB disk
eg :qemu-img create -f raw /home/my-data-disk.raw 5G
2.Start VM with virtio-scsi
CLI:/usr/libexec/qemu-kvm -cpu SandyBridge -M rhel6.5.0 -enable-kvm -m 2G -smp 2,sockets=2,cores=1,threads=1 -name rhel6.4-64 -uuid 9a0e67ec-f286-d8e7-0548-0c1c9ec93009 -nodefconfig -nodefaults -monitor stdio -rtc base=utc,clock=host,driftfix=slew -no-kvm-pit-reinjection -no-shutdown -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -drive file=/home/win7-32-virtio.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -device virtio-scsi-pci,bus=pci.0,addr=0x6,id=scsi0 -drive file=/home/my-data-disk.raw,format=raw,if=none,id=scsi-disk,cache=none,werror=stop,rerror=stop,aio=native -device scsi-hd,drive=scsi-disk,bus=scsi0.0,id=hd-scsi -vnc :0  -vga cirrus  -netdev tap,id=hostnet0,vhost=on -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:d5:51:8a,bus=pci.0,addr=0x3
3.Shrink the disk to 2GB
(qemu) block_resize scsi-disk 2G
4.Format disk
5.reboot guest
6.format disk

Actual results:
Disk can not be formatted in Both step4 and step6


Expected results:
It should be formatted successfully

Additional info:
Comment 1 Vadim Rozenfeld 2013-09-22 07:57:18 EDT
Hi MIke,
What kind of error messages do you get on step4/6?
What happens if you delete and then create a new partition
after step 3?

Thanks,
Vadim.
Comment 3 Mike Cao 2013-09-24 08:16:28 EDT
(In reply to Vadim Rozenfeld from comment #1)
> Hi MIke,
> What kind of error messages do you get on step4/6?
> What happens if you delete and then create a new partition
> after step 3?
> 
> Thanks,
> Vadim.

I can not reproduce it on build 71
The disk can be formatted after step3
Comment 4 Mike Cao 2013-09-24 08:20:23 EDT
(In reply to Mike Cao from comment #3)
> (In reply to Vadim Rozenfeld from comment #1)
> > Hi MIke,
> > What kind of error messages do you get on step4/6?
> > What happens if you delete and then create a new partition
> > after step 3?
> > 
> > Thanks,
> > Vadim.
> 
> I can not reproduce it on build 71
> The disk can be formatted after step3

I mean on win2012 ,I will try win7-32 tmr
Comment 5 Ronen Hod 2013-09-24 09:58:53 EDT
I expect the following
1. In Windows: Shrink the partition and its file system (this could be complicated, since the file-system can be too full)
2. In QEMU: resize (reduce the disk)
3. In Windows disk manager: rescan the hardware to discover the disk size
It is not clear how it should work if a disk is shrunk and part of the file-system's disk is removed.
I think that we shall close this bug.

Ronen.
Comment 6 Ronen Hod 2013-10-13 08:07:20 EDT
Mike,

Can we close this bug?
Comment 7 lijin 2013-10-13 23:27:40 EDT
retest on win7-64 guest with build 72,cannot reproduce this issue,disk can be formatted correctly.

package info:
    Red Hat Enterprise Linux Server release 6.4 (Santiago)
    qemu-kvm-rhev-0.12.1.2-2.355.el6_4.9.x86_64
    kernel-2.6.32-358.21.1.el6.x86_64
    seabios-0.6.1.2-28.el6.x86_64
    vgabios-0.6b-3.7.el6.noarch
    virtio-win-prewhql-72
Comment 8 Mike Cao 2013-10-13 23:31:30 EDT
Move status to VERIFIED according to comment #7

Note You need to log in before you can comment on or make changes to this bug.