Bug 990994 - systemd-206 requires kmod-14
systemd-206 requires kmod-14
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 07:16 EDT by Bruce Jerrick
Modified: 2013-09-13 07:39 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-13 07:39:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Jerrick 2013-08-01 07:16:47 EDT
Description of problem:
The 'kmod-static-nodes' service added to systemd-206 invokes
'/usr/bin/kmod static-nodes ...', which is new to kmod-14, but
systemd does not have a Requires on kmod-14 .

Version-Release number of selected component:
systemd-206-1.fc20

'rpm' does not complain if a system with kmod-13 is upgraded to systemd-206 .
But that combination will produce the following message at boot time:

  Failed to start Create list of required static device nodes for the current kernel.

because the new /usr/lib/systemd/system/kmod-static-nodes.service invokes:

  ExecStart=/usr/bin/kmod static-nodes --format=tmpfiles --output=/run/tmpfiles.d/kmod.conf

and the 'static-nodes' command first appeared in kmod version 14 .

Granted that this is (was) likely to happen only on a Frankensystem (new parts
and old parts); nonetheless, the requirement is clearly there.

FIX: This should be added to the systemd spec file:

    Requires: kmod >= 14
Comment 1 Marcos Mello 2013-08-19 18:47:09 EDT
Yep, it's on README (one commmit after 206).

http://cgit.freedesktop.org/systemd/systemd/commit/?id=f4f8f7b546

The requirement will probably be bumped again once kmod 15 is released, since the plan is to drop ExecStartPre from the service file.

http://thread.gmane.org/gmane.comp.sysutils.systemd.devel/11676/focus=11781
Comment 2 Jóhann B. Guðmundsson 2013-08-20 05:51:15 EDT
Can someone remind me why are we shipping that unit in the systemd when it truly  belongs in kmod and can affect container setups?
Comment 4 Lennart Poettering 2013-09-12 20:54:23 EDT
Fixed in fedora systemd git.
Comment 5 Harald Hoyer 2013-09-13 07:39:38 EDT
systemd-207

Note You need to log in before you can comment on or make changes to this bug.