Bug 991046 - No wheel button when open "Dokumentenbetrachter" probably this means evince...
No wheel button when open "Dokumentenbetrachter" probably this means evince...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Kašík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 09:20 EDT by Soren Wacker
Modified: 2014-11-14 09:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-14 09:22:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Soren Wacker 2013-08-01 09:20:29 EDT
Description of problem:
When opening evince without a file the wheel-button is not visible.




Version-Release number of selected component (if applicable):
evince --version gives:
GNOME Dokumentenbetrachter 3.8.3
(here should be the name EVINCE be included!)

How reproducible:
easy

Steps to Reproduce:
1. Open evince without a file
2. click on the gripper
3. the wheel button appears

Actual results:
the wheel button is not present when open evince, but is needed for example to open a file

Expected results:
the wheel button should be present
Comment 1 Marek Kašík 2014-05-19 12:22:20 EDT
Hi Soren,

I see the icon there but it disappears when the window is too narrow to show it (without showing an expander). Is this the problem you describe?

Regards

Marek
Comment 2 Soren Wacker 2014-05-23 01:52:00 EDT
Yes, I thing it is.
Comment 3 Marek Kašík 2014-05-29 04:40:33 EDT
Hi Soren,

I've tried to fix this but since gtk doesn't give me information about missing space for the icon in the toolbar I can not fix it properly. This will probably need an API change. I'll return to this later.

Regards

Marek
Comment 4 Marek Kašík 2014-11-14 09:22:03 EST
This has been fixed in evince-3.14 by replacing the toolbar by a headerbar. The headerbar doesn't not shrink to the point where the icons disappear.
I don't plan to backport this or search for another fix for older releases.
I'm closing this then.

Note You need to log in before you can comment on or make changes to this bug.