Bug 991063 - ovirt-shell fails on ovirt 3.2 on RHEL6 because pexpect_u dependency cannot be met
ovirt-shell fails on ovirt 3.2 on RHEL6 because pexpect_u dependency cannot b...
Status: CLOSED WONTFIX
Product: oVirt
Classification: Community
Component: ovirt-engine-cli (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3
Assigned To: Michael Pasternak
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 09:50 EDT by jas
Modified: 2014-01-12 19:39 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 03:19:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jas 2013-08-01 09:50:26 EDT
After installation of oVirt on RHEL6 with both the oVirt and EPEL repositories enabled, if one tries to run ovirt-shell it fails because a dependency pexpect_u is not installed.  This dependency is not available in the EPEL repository, not available in the RHEL6 repository, and must be downloaded and installed separately.  For example here:

https://pypi.python.org/packages/3.2/p/pexpect-u/

This dependency should be added to either the RHEL6 ovirt repository, or the instructions should be updated with a different repository that must be enabled to get this package.  If ovirt-shell requires this dependency, yum shouldn't install it because the dependency cannot be met.
Comment 1 Michael Pasternak 2013-08-08 03:19:15 EDT
well this is a chicken and egg situation, ovirt can't run on fedora cause it 
doesn't have pexpect (forked and no longer maintained for fedora), instead
we using latest version pexpect-u, which is yet not available in rhel, in 3.3
there is no pexpect dependency at all, so i guess in 3.2 you should be just
installing it manually,

as we don't need it for the future versions, we won't be backporting pexpect-u
to rhel

Note You need to log in before you can comment on or make changes to this bug.