Bug 991081 - Red Hat Storage nodes, attached to 'Gluster Enabled Cluster', are shown in drop-down box for choosing host, while removing Storage Domain
Red Hat Storage nodes, attached to 'Gluster Enabled Cluster', are shown in dr...
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.2.0
All Linux
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Daniel Erez
Leonid Natapov
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-01 10:47 EDT by Rejy M Cyriac
Modified: 2016-02-10 15:06 EST (History)
10 users (show)

See Also:
Fixed In Version: is12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
virt rhev integration
Last Closed: 2013-09-01 06:59:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: Triaged+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18235 None None None Never

  None (edit)
Description Rejy M Cyriac 2013-08-01 10:47:59 EDT
Description of problem:
In a POSIX compliant FS Data Center, with separate 'Virt Enabled Cluster' and 'Gluster Enabled Cluster', the Red Hat Storage nodes attached to 'Gluster Enabled Cluster', are shown, along with the Hypervisor nodes attached to the 'Virt Enabled Cluster', in the drop-down box for choosing host, while removing Storage Domain. If the Red Hat Storage node is chosen, the operation will fail, because the operation actually requires a Hypervisor node.

Bug 972742 fixed a similar issue that was observable while creating a new Storage Domain, and while creating new VM

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.2.2-0.41.el6ev 

How reproducible:


Steps to Reproduce:
1.Create a POSIX compliant FS Data Center, with separate 'Virt Enabled Cluster' and 'Gluster Enabled Cluster', and add Hypervisor nodes and Red Hat Storage nodes to respective clusters.
2.Add 2 Storage Domains to the Data Center, of which one will be assigned as the master
3.Detach the Storage Domain which is not the master 
4.Attempt to remove the unattached Storage Domain
5. In the resulting dialog box, observe the list of hosts in the drop-down box for 'Select Host to be used'

Actual results:
Red Hat Storage nodes, attached to 'Gluster Enabled Cluster', are shown in the drop-down box for choosing host, while removing Storage Domain 

Expected results:
Red Hat Storage nodes, attached to 'Gluster Enabled Cluster', should not be shown in the drop-down box for choosing host, while removing Storage Domain. Only Hypervisor nodes, attached to 'Virt Enabled Cluster' should be shown here.

Additional info:

Note You need to log in before you can comment on or make changes to this bug.