Bug 991289 - edit-node can't install multiple packages as manpage said
edit-node can't install multiple packages as manpage said
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Ryan Barry
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 01:26 EDT by wanghui
Modified: 2014-06-09 10:07 EDT (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-8.el6
Doc Type: Bug Fix
Doc Text:
The 'manpage' of 'edit-node' said, multiple packages could be installed using a comma to separate each item. However, this format was not supported. This occurred because 'edit-node' was not parsing the correctly. The parsing has been fixed, so now multiple packages can be installed by listing them with a comma separating each item.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:47:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rbarry: needinfo-


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20407 None None None Never

  None (edit)
Description wanghui 2013-08-02 01:26:02 EDT
Description of problem:
It can't install multiple packages using comma to separated them using edit-node. As the manpage of edit-node said, this format is supported.

Run the command as follows:
#edit-node --repo=/etc/yum.repos.d/edit-node.repo --install=/root/Downloads/ovirt-node-plugin-cim-3.0.0-6.1.el6.noarch.rpm,/root/Downloads/ovirt-node-plugin-snmp-3.0.0-6.1.el6.noarch.rpm /home/rhev-hypervisor6-6.5-20130725.0.iso

The man page of edit-node said as follows.
--install=PACKAGE_NAME
              Installs a the specific package from a yum repo or specified rpm
              file, all file locations are valid.  Multiple  packages  can  be
              specified by comma delimited list (package1,package2)

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130725.0.iso
ovirt-node-3.0.0-6.1.el6.noarch
ovirt-node-tools-3.0.0-6.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1.Run command
#edit-node --repo=/etc/yum.repos.d/edit-node.repo --install=/root/Downloads/ovirt-node-plugin-cim-3.0.0-6.1.el6.noarch.rpm,/root/Downloads/ovirt-node-plugin-snmp-3.0.0-6.1.el6.noarch.rpm /home/rhev-hypervisor6-6.5-20130725.0.iso

Actual results:

1. After run the command, the output is as follows.

/home/rhev-hypervisor6-6.5-20130725.0.iso
Setting SELinux Permissive During Yum Install
Installing Packages
Setting Up DNS For Chroot
Configuring Yum Repo
Running Yum Install
http://ovirt.org/releases/stable/rpm/EL/6Server/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Setting up Install Process
No package /root/Downloads/ovirt-node-plugin-cim-3.0.0-6.1.el6.noarch.rpm,/root/Downloads/ovirt-node-plugin-snmp-3.0.0-6.1.el6.noarch.rpm available.
Error: Nothing to do

Yum Install Failed
http://ovirt.org/releases/stable/rpm/EL/6Server/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Setting up Install Process
No package /root/Downloads/ovirt-node-plugin-cim-3.0.0-6.1.el6.noarch.rpm,/root/Downloads/ovirt-node-plugin-snmp-3.0.0-6.1.el6.noarch.rpm available.
Error: Nothing to do

Cleaning Up Yum Configuration
umount: /var/tmp/dd-isouMn154: not mounted
Returning SELinux To Enforcing

Expected results:
1. Multiple packages should be installed successfully.

Additional info:
1. It doesn't work with --install-plugin also.
2. No such issue when install one package at a time.
Comment 2 RHEL Product and Program Management 2013-10-13 22:52:17 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 Cheryn Tan 2014-01-08 00:35:46 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thank you for your help.
Comment 6 wanghui 2014-01-13 00:23:03 EST
Test version:
rhevh-6.5-20140110.1.iso
ovirt-node-3.0.1-16.el6_5.noarch
ovirt-node-tools-3.0.1-16.el6_5.noarch

Test steps:
1. Run the follow command.
   #edit-node --repo=/home/edit-node/edit-node.repo --install=ovirt-node-plugin-ipmi-3.0.1-16.el6_5.noarch.rpm,ovirt-node-plugin-puppet-3.0.1-16.el6_5.noarch.rpm rhevh-6.5-20140110.1.iso 
2. Install the edited iso.

Test result:
1. After step1, it can generated a iso named 'rhevh-6.5-20140110.ipmi_puppet.1.iso'.
2. After step2, the edited iso can be installed. And the two plugins are listed.

So the bug is fixed in rhevh-6.5-20140110.1.iso. Change the status from ON_QA to VERIFIED.
Comment 8 errata-xmlrpc 2014-01-21 14:47:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.