Bug 991357 - The guest display will keep flickering after change it's resolution sevral times
The guest display will keep flickering after change it's resolution sevral times
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-qxl (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Default Assignee for SPICE Bugs
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 04:30 EDT by CongDong
Modified: 2014-08-15 08:48 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-15 08:48:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (1.08 MB, text/x-log)
2013-08-04 23:14 EDT, CongDong
no flags Details

  None (edit)
Description CongDong 2013-08-02 04:30:19 EDT
Description of problem:
When I change the resolution of a guest with two displays under full-screen mode sevral times, the display will keep flickering.
So I have to restart the guest to stop that.

Version-Release number of selected component (if applicable):
spice-gtk-0.20-3.el6.x86_64
virt-viewer-0.5.6-6.el6.x86_64
spice-vdagent-0.14.0-1.el6.x86_64
spice-glib-0.20-3.el6.x86_64
libvirt-0.10.2-21.el6.x86_64
qemu-kvm-0.12.1.2-2.382.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Prepare a machine with two physical monitors.
2.Create a rhel guest with spice+qxl+spicevmc,and install spice-vdagent in it.
3.# virt-viewer $guest , check on the "Automatically resize", and type 'f11' to change to fullscreen.
4.Make sure can see the two displays of guest are full-screen on each monitor.
5.Change the resolution to a higher one than native resolution sevral times.

Actual results:
The display will keep flickering.

Expected results:
The display should not keep flickering.
And it should change the resolution which I choosed and keep stable.

Additional info:
Comment 2 Marc-Andre Lureau 2013-08-02 11:36:28 EDT
Is this bug happening with both linux and windows guests? So far, I can reproduce only with current RHEL6.

Can you precise the guest OS, release version, if the spice agent is running, and its version. thanks

(my gut feeling is that it is a linux vdagent bug, but I need to do more research)
Comment 3 Marc-Andre Lureau 2013-08-03 11:33:59 EDT
I didn't find yet the root cause, however, I can reproduce without vdagent. It doesn't need multimonitor guest.

Moving to bug QXL component (0.1.0-4.el6).
Comment 4 Marc-Andre Lureau 2013-08-03 11:44:50 EDT
Current upstream/master code doesn't exhibit the bug, however it makes Xorg consume 33% cpu constantly. I removed the edid code from RHEL 0.1.0-4.el6, it seems to help (more testing needed)
Comment 5 CongDong 2013-08-04 23:14:56 EDT
Created attachment 782645 [details]
Xorg.0.log

(In reply to Marc-Andre Lureau from comment #2)
> Is this bug happening with both linux and windows guests? So far, I can
> reproduce only with current RHEL6.
> 
> Can you precise the guest OS, release version, if the spice agent is
> running, and its version. thanks
> 
> (my gut feeling is that it is a linux vdagent bug, but I need to do more
> research)

Yes, you're right, I can reproduce this without multi-monitor

The guest's OS is RHEL6.4-20130123.0 x86_64

spice-vdagent is running in guest, it's version is:
spice-vdagent-0.12.0-4.el6.x86_64

I add the xorg.0.log to attachment.

BTW, I update the spice-vdagent to the lastest version, it's hard to reproduce, but I change the resolution about 20 times, the guest start to flicker.
Comment 6 RHEL Product and Program Management 2013-10-13 22:52:02 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 Marc-Andre Lureau 2014-08-14 14:52:06 EDT
CongDong, I can't reproduce this flickering anymore.

In comment 4, I tried removing edid and it helped. Since EDID has been removed in 0.1.1, it may be the reason why this is now fixed. Please check
Comment 9 CongDong 2014-08-15 00:04:54 EDT
I (In reply to Marc-Andre Lureau from comment #8)
> CongDong, I can't reproduce this flickering anymore.
> 
> In comment 4, I tried removing edid and it helped. Since EDID has been
> removed in 0.1.1, it may be the reason why this is now fixed. Please check

I tested with xorg-x11-drv-qxl-0.1.0-4.el6
It's easy to reproduce.


Also tested with xorg-x11-drv-qxl-0.1.0-7.el6 and xorg-x11-drv-qxl-0.1.1-13.el6
Cannot reproduce with them.
Comment 10 Marc-Andre Lureau 2014-08-15 08:48:45 EDT
thanks

Note You need to log in before you can comment on or make changes to this bug.