Bug 991381 - [Windows Guest Tools] Windows 7 64bit - After upgrade from 3.2.12 to 3.3.3 / Windows could not start the RHEV Agent service on Local Computer
[Windows Guest Tools] Windows 7 64bit - After upgrade from 3.2.12 to 3.3.3 / ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent (Show other bugs)
3.2.0
Unspecified Unspecified
high Severity high
: ---
: 3.3.0
Assigned To: Lev Veyde
Jiri Belka
integration
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 05:59 EDT by Jiri Belka
Modified: 2015-09-22 09 EDT (History)
8 users (show)

See Also:
Fixed In Version: rhev-guest-tools-iso-3.3-6
Doc Type: Bug Fix
Doc Text:
After upgrading the Windows Guest Tools using the Application Provisioning Tool, the rhev-agent service could not be started. This was caused by a bug in the way InstallShield 2012's InstallScript engine runs under MSI. The USB installer has been modified to fix the regression caused by the change in the InstallShield engine. Now the rhev-agent service runs as expected after a Guest Tools upgrade.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 10:55:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
installogs (248.43 KB, application/zip)
2013-08-02 05:59 EDT, Jiri Belka
no flags Details

  None (edit)
Description Jiri Belka 2013-08-02 05:59:08 EDT
Created attachment 781905 [details]
installogs

Description of problem:

After upgrading via APT Windows Guest Tools from 3.2.12 to 3.3.3, RHEV agent service is not running.

* when starting RHEV Agent service manually

Windows could not start the RHEV Agent service on Local Computer.

Error 1075: The dependency service does not exist or has been marked for deletion.

  - its dependencies are:

    Remote Desktop Services
    > Remote Procedure Call (RPC)
      > DCOM Server Process Launcher
      > RPC Endpoint Mapper
    > Terminal Device Driver

* event from eventlog

The description for Event ID 3 from source OVirtGuestService cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event: 

Traceback (most recent call last):
  File "win32serviceutil.pyc", line 806, in SvcRun
  File "OVirtGuestService.pyc", line 55, in SvcDoRun
  File "GuestAgentWin32.pyc", line 384, in __init__
  File "OVirtAgentLogic.pyc", line 64, in __init__
  File "VirtIoChannel.pyc", line 93, in __init__
  File "WinFile.pyc", line 39, in __init__
error: (5, 'CreateFile', 'Access is denied.')

the message resource is present but the message is not found in the string/message table

* components listed for 3.2.12

RHEV-Application Provisioning Tool
RHEV-Spice64
RHEV-Spice-Agent64
RHEV-Tools
  > RHEV virtio-serial
  > RHEV spice agent (not checked on W7 64bit/but checked on W7 32bit)
  > RHEV spice driver (not checked on W7 64bit/but checked on W7 32bit)
  > RHEV network
  > RHEV agent
  > RHEV USB
  > RHEV sso
  > RHEV block
  > RHEV balloon

* components listed after upgrade to 3.3.3

RHEV-Application Provisioning Tool
RHEV-Spice64
RHEV-Spice-Agent64
RHEV-Tools
  > RHEV virtio-serial
  > RHEV spice agent (not checked)
  > RHEV spice driver (not checked)
  > RHEV network
  > RHEV agent
  > RHEV USB
  > RHEV sso
  > RHEV block
  > RHEV balloon
  > RHEV SCSI (not checked)
  > RHEV Qemu GA (not checked)

* installing RHEV SCSI, RHEV Qemu GA components makes no difference but after reboot RHEV spice agent, RHEV spice driver disappear from list of installed apps! current list is

RHEV-Application Provisioning Tool
RHEV-QGA
RHEV-Tools
  > RHEV virtio-serial
  > RHEV spice agent (not checked)
  > RHEV spice driver (not checked)
  > RHEV network
  > RHEV agent
  > RHEV USB
  > RHEV sso
  > RHEV block
  > RHEV balloon
  > RHEV SCSI
  > RHEV Qemu GA

installing RHEV spice agent, RHEV spice driver (change -> modify - select all) and then after reboot repairing installation (chage -> repair) does not solve the issue. the service cannot be still started.



Version-Release number of selected component (if applicable):
is7 (3.3.3) upgraded from 3.2.12 (on 3.2 vdsm - vdsm-4.10.2-24.0.el6ev.x86_64)

How reproducible:
100%

Steps to Reproduce:
1. install 3.2.12 and ugprade via APT to 3.3.3
2.
3.

Actual results:
RHEV Agent cannot be started

Expected results:
working 3.3.3 tools

Additional info:
installing 3.3.3 tools on clean windows works OK, thus the issue happens only when upgrading
Comment 1 Jiri Belka 2013-08-02 08:14:08 EDT
Above report was for Windows 7 64bit, interestingly Windows 7 32bit works ok.
Comment 2 Jiri Belka 2013-08-02 09:14:57 EDT
Ignore additional info in comment #0, it works strangly even when clean installation, something is broken, I didn't got listed all installed apps in vdsClient and after reboot the RHEV agent service cannot be started, strange it had to run as I got partial list of installed apps in Admin Portal and vdsClient.
Comment 10 Jiri Belka 2013-09-20 10:44:39 EDT
Same on clean install with 3.3.5 and Windows 7 64bit. This impacts some SPICE features.
Comment 12 Jiri Belka 2013-10-07 10:28:02 EDT
ok, 3.3.6.
Comment 13 Charlie 2013-12-11 21:34:57 EST
Hi all, what was the final fix on this?
Comment 14 Lev Veyde 2013-12-12 06:49:05 EST
(In reply to Charlie from comment #13)
> Hi all, what was the final fix on this?

The USB installer was modified to fix the regression caused by change in the IS engine.
Comment 15 errata-xmlrpc 2014-01-21 10:55:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0075.html

Note You need to log in before you can comment on or make changes to this bug.