Bug 9914 - RH 6.1 mount mounts smbfs as root only
RH 6.1 mount mounts smbfs as root only
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-02 03:25 EST by Disco Stu
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-03 02:05:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Disco Stu 2000-03-02 03:25:38 EST
Whenever I mount a smbfs share no matter which options i use its always
mounted with root permissions. I used this line to mount my smb share in
6.0 and it worked fine but in 6.1 it mounts as root.

mount -t smbfs -o guest,uid=501 //server/share/ /home/dir/dir

The UID 501 is a valid user!

I tried using other otpions such as umask=777 gid=50 rw fmask=777 in all
sorts of combinations with no luck

The share mounts ok but the permission are set to that of root and other
users can't modify or add files to that share.
Comment 1 Bill Nottingham 2000-03-02 12:32:59 EST
The options to smbmount changed. This is fixed as of
samba-2.0.6, but there is still a slightly different syntax.
Comment 2 Disco Stu 2000-03-03 02:05:59 EST
yep that fixed it
thanks

Note You need to log in before you can comment on or make changes to this bug.