Bug 991406 - grub not boot after fresh install -- could not find '/grub2/i386-pc/normal.mod'
grub not boot after fresh install -- could not find '/grub2/i386-pc/normal.mod'
Status: CLOSED DUPLICATE of bug 991404
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 07:29 EDT by Joan Aymà
Modified: 2013-08-05 10:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 10:59:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 986345 None None None Never

  None (edit)
Description Joan Aymà 2013-08-02 07:29:24 EDT
Description of problem:

Did a fresh install with a custom partition schema, /boot on a primary partition, and /, /opt, /var on a lvm vg. All on same disk. After reboot, grub came on rescue console, complaining about not finding '/grub2/i386-pc/normal.mod'. And indeed the file was not there.

I did

  grub2-install --recheck /dev/sda

after rebooting again to live usb, which solved the problem.

There's an entry on anaconda.log that installs bootloader on /dev/sda, then /dev/sdb. During install /dev/sda was Fedora's live usb stick, and at next reboot, /dev/sda was Fedora's recent install.

If needed I could reproduce the problem on another machine
Comment 1 Joan Aymà 2013-08-05 10:59:46 EDT

*** This bug has been marked as a duplicate of bug 991404 ***

Note You need to log in before you can comment on or make changes to this bug.