Bug 991522 - Differences in anaconda installation screens and warnings, when installing Red Hat Storage 2.1 from ISO, and when installing over the network
Differences in anaconda installation screens and warnings, when installing Re...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: distribution (Show other bugs)
2.1
Unspecified Linux
high Severity high
: ---
: ---
Assigned To: Anthony Towns
Rejy M Cyriac
:
Depends On: 996830
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 12:09 EDT by Rejy M Cyriac
Modified: 2014-07-11 02:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:32:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot_Title (195.25 KB, image/png)
2013-08-13 10:15 EDT, Rejy M Cyriac
no flags Details
Screenshot_ISO_RHEL6_Title (243.83 KB, image/png)
2013-08-13 10:16 EDT, Rejy M Cyriac
no flags Details
Screenshot_NW_pre-release_warning (78.81 KB, image/png)
2013-08-13 10:16 EDT, Rejy M Cyriac
no flags Details
Screenshot_ISO_pre-release_warning (83.04 KB, image/png)
2013-08-13 10:17 EDT, Rejy M Cyriac
no flags Details
Screenshot_ISO_NetworkConfigScreen (39.61 KB, image/png)
2013-08-13 10:17 EDT, Rejy M Cyriac
no flags Details

  None (edit)
Description Rejy M Cyriac 2013-08-02 12:09:41 EDT
Description of problem:
On installing Red Hat Storage 2.1 from the ISO - RHS-2.1-20130801.n.0-RHS-x86_64-DVD1.iso - it is observable that the following anaconda installation screens and warnings are not shown. This is in comparison to an installation over the network.

1) Initial Title Screen of Red Hat Storage 2.1
2) The warning pop-up after the title screen on this being a pre-release software.
3) The screen displaying options to choose 'Storage Device Type'
4) The 'Storage Device Warning' pop-up that the storage device contains data, and data may be lost.
5) The screen to configure the system hostname, and to configure the network settings
6) The screen to select timezone
7) After custom partitioning, the pop-up asking whether to write storage configuration to disk.

Among these the absence of 5) and 6) is particularly important, since it impacts system configuration.

The first screen that comes up on installing from the ISO is the screen to set the root password, instead of the 'Title Screen'

Another observation is that the last anaconda installation screen, where choice to select among gluster components is provided, is available when installing from ISO, but is not available when installing over the network.

Version-Release number of selected component (if applicable):
RHS-2.1-20130801.n.0-RHS-x86_64-DVD1.iso

How reproducible:


Steps to Reproduce:
1.Install the same RHS version using ISO, and over the network, and observe differences in anaconda screens and warnings..

Actual results:
There are differences in the anaconda installation screens and warnings, when installing Red Hat Storage 2.1 from ISO, and when installing over the network

Expected results:
The anaconda installation screens and warnings, when installing Red Hat Storage 2.1 from ISO, and when installing over the network, should be the same.

Additional info:
Comment 2 Anthony Towns 2013-08-08 21:53:36 EDT
I don't think there's anything to be done about these issues. Network installs should be done by customers skilled enough to craft a kickstart file to ensure they get the configuration options they desire...
Comment 3 Rejy M Cyriac 2013-08-12 01:32:08 EDT
AJ,

I think that you have missed the point. The missing screens and warnings are in the *ISO* install, and there are seven of them that I have noted. Please refer to Comment 0 (Description) of this BZ.

The network install only misses one screen at the very end, which may be ignored, based on your line of reasoning.

But I believe that, since the ISO installs are supposed to be interactive, all the screens and warnings should be there. So I am re-opening this BZ for another look at this.
Comment 4 Sayan Saha 2013-08-12 19:30:54 EDT
If we are missing the installer screens that were in Anshi/U5 while doing an ISO install then we have regressed and that is a problem. We need to add these screens back. I agree that screens mentioned in 5) and 6) need to be there.
Comment 5 Anthony Towns 2013-08-13 01:42:43 EDT
(In reply to Rejy M Cyriac from comment #0)
> Description of problem:
> On installing Red Hat Storage 2.1 from the ISO -
> RHS-2.1-20130801.n.0-RHS-x86_64-DVD1.iso - it is observable that the
> following anaconda installation screens and warnings are not shown. This is
> in comparison to an installation over the network.

Using the RHS-2.1-20130813.n.0 ISO to install a vm  I get the following screens:

 0) Grub boot screen
 1) Media test
 2) Logo/Title screen
 3) Language selection
 4) Keyboard selection
 5) Pre-release warning
 6) Storage device type
 7) Hostname (with Configure Network button)
 8) Timezone
 9) Root password
10) "Use all space", etc partitioning screen
11) Write changes to disk?
12) Package selections / repos
13) Actual installation 
14) Reboot

Cheers,
aj
Comment 6 Rejy M Cyriac 2013-08-13 10:14:17 EDT
Aj,

The issue was reported against a specific version of RHS ISO compose, as can be seen in the 'Description' :

------------------------------------------------------------

Version-Release number of selected component (if applicable):
RHS-2.1-20130801.n.0-RHS-x86_64-DVD1.iso

------------------------------------------------------------

The reported fix to the issue was made available in a later version of RHS ISO compose - RHS-2.1-20130813.n.0-RHS-x86_64-DVD1.iso

So I do not believe that the BZ can be closed as 'CLOSED WORKSFORME'. I would expect that once a fix is reportedly in place, the BZ should be moved to 'ON_QA', so that it may be qualified.

-----#####-----

I have examined the Screens and Warnings available in RHS-2.1-20130813.n.0-RHS-x86_64-DVD1.iso , as opposed to what was available in the previous version. I am happy to report that the missing screens and warnings have come back. :-)

But I have a few reservations, which I report below. I would like to hear your take on them.

1) The title screen has both the menu text and background image text in white. This makes it hard to read. [1]. Compare this with the RHEL 6 title screen, which has the right contrast [2].

2) On a network install, the pre-release warning comes up at the next step to the title screen [3]. But on the ISO install, it comes up at the next step to configuring keyboard settings [4]. This is not a big issue, as it is to be taken off at GA anyway, but I am still curious as to the cause of the difference in behaviour, and it should not impact its removal at GA.

3) On an ISO install, the network interface is *by default turned off*, and it is required to use the button at the bottom left of the 'hostname & network config' screen to have it turned on by default [5], or it would have to be done post-install. On a network install, it is *by default turned on*, since the network interface is being used for installation. This is the same as for RHEL 6, but I have brought it up here, so that it may be confirmed as okay for RHS install by ISO, and documented if required, and not come as a surprise later.

[1] - Screenshot_Title.png
[2] - Screenshot_ISO_RHEL6_Title.png
[3] - Screenshot_NW_pre-release_warning.png
[4] - Screenshot_ISO_pre-release_warning.png
[5] - Screenshot_ISO_NetworkConfigScreen.png
Comment 7 Rejy M Cyriac 2013-08-13 10:15:34 EDT
Created attachment 786171 [details]
Screenshot_Title
Comment 8 Rejy M Cyriac 2013-08-13 10:16:11 EDT
Created attachment 786172 [details]
Screenshot_ISO_RHEL6_Title
Comment 9 Rejy M Cyriac 2013-08-13 10:16:39 EDT
Created attachment 786173 [details]
Screenshot_NW_pre-release_warning
Comment 10 Rejy M Cyriac 2013-08-13 10:17:00 EDT
Created attachment 786174 [details]
Screenshot_ISO_pre-release_warning
Comment 11 Rejy M Cyriac 2013-08-13 10:17:23 EDT
Created attachment 786175 [details]
Screenshot_ISO_NetworkConfigScreen
Comment 12 Rejy M Cyriac 2013-08-13 10:20:52 EDT
And what happened to the elusive last anaconda installation screen, where choice to select among gluster components was being provided, when installing from ISO, but not when installing over the network ?

Now that screen is not available for both types of install. I am happy with the current consistency, but I would like to know whether that screen/choice has now been deprecated.
Comment 13 Anthony Towns 2013-08-13 12:17:59 EDT
(In reply to Rejy M Cyriac from comment #6)
> The issue was reported against a specific version of RHS ISO compose, as can
> be seen in the 'Description' :

Yep. So what's happened here is that the latest compose (0813.n.0) included a change that removed the isolinux.cfg and hence the overriden kickstart. This resulted in the changes you've seen -- first the grub menu; and secondly the changes in anaconda behaviour. That change wasn't meant to go in, so these bug fixes are rather accidental...

> But I have a few reservations, which I report below. I would like to hear
> your take on them.
> 1) The title screen has both the menu text and background image text in
> white. This makes it hard to read. [1]. Compare this with the RHEL 6 title
> screen, which has the right contrast [2].

Agreed; this should probably be a separate bz against the redhat-storage-logos package to get a better grub background image.

> 3) On an ISO install, the network interface is *by default turned off*, and

This was overriden as part of the isolinux.cfg, in particular the "asknetwork" option.
Comment 14 Rejy M Cyriac 2013-08-13 12:21:50 EDT
Sayan,

The latest RHS spin - RHS-2.1-20130813.n.0-RHS-x86_64-DVD1.iso - looks good, and has brought down the differences between the RHS ISO and RHS Network-Based installs close to zero.

There are two remaining differences, which I have captured in Comment 6 , of which 2) is trivial (to be gone by GA) and 3) is expected behaviour for install type. And 1) is not about a difference, but just deals with aesthetics.

Could we have your take on this ?
Comment 15 Sayan Saha 2013-08-13 17:04:54 EDT
Rejy,

I think we are pretty close now and should probably close the bug if you think it's ok to do so. Or we can keep it open until the 1) above is addresed by GA.
Comment 16 Sayan Saha 2013-08-13 17:05:10 EDT
Rejy,

I think we are pretty close now and should probably close the bug if you think it's ok to do so. Or we can keep it open until the 1) above is addressed by GA.
Comment 17 Rejy M Cyriac 2013-08-14 01:44:07 EDT
(In reply to Sayan Saha from comment #16)
> Rejy,
> 
> I think we are pretty close now and should probably close the bug if you
> think it's ok to do so. Or we can keep it open until the 1) above is
> addressed by GA.

Thanks Sayan for the comments.

I have opened BZ for the grub screen changes - Bug 996830 - Improve readability of menu text at grub screen on RHS 2.1 ISO installation. Made this BZ dependent on the new BZ.
Comment 19 Anthony Towns 2013-08-20 18:14:20 EDT
(In reply to Rejy M Cyriac from comment #17)
> (In reply to Sayan Saha from comment #16)
> > I think we are pretty close now and should probably close the bug if you
> > think it's ok to do so. Or we can keep it open until the 1) above is
> > addressed by GA.
> I have opened BZ for the grub screen changes - Bug 996830 - Improve
> readability of menu text at grub screen on RHS 2.1 ISO installation. Made
> this BZ dependent on the new BZ.

996830 is ON_QA, so moving this one to ON_QA too
Comment 20 Rejy M Cyriac 2013-08-30 10:49:13 EDT
Verified with RHS-2.1-20130830.n.0-RHS-x86_64-DVD1 ISO
Comment 21 Scott Haines 2013-09-23 18:32:15 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.