Bug 99154 - rpm --excludepath for multiple directories.
Summary: rpm --excludepath for multiple directories.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL: http://www.rpm.org
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-15 08:23 UTC by Ilan Shufer
Modified: 2007-04-18 16:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-29 13:08:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ilan Shufer 2003-07-15 08:23:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030425

Description of problem:
I'm sure this is not the first bug about --excludepath but i would like to some
all the problems i'm seeing.
1.rpm-3x had --excludepath as an option but didn't work at all.
2.rpm-4x has this option and generally works with one directory but there are
still gliches(like rpm-4.1-1.06)
3.Only rpm-4.0.2-8(which came with RH7.1) has the ability to exclude multiple
directories.

Weird , i looked at the code and it seems a fix for multiple exclude is
there(diffs between rpm-4.0 to 4.0.2-8)
" case GETOPT_EXCLUDEPATH:
            if (*optArg != '/')
                argerror(_("exclude paths must begin with a /"));
            relocations = xrealloc(relocations,
                           sizeof(*relocations) * (numRelocations + 1));
            relocations[numRelocations].oldPath = optArg;
            relocations[numRelocations++].newPath = NULL;
            break;"

but when i check if these lines are in rpm-4.0.3 they exist and still it doesn't
work.
Maybe its a problem with popt or some other external library?

Please , formally , Is there a way to -excludepath multiple directories or not?

Version-Release number of selected component (if applicable):
rpm-4.1-1.06

How reproducible:
Always

Steps to Reproduce:
1.Prepare an rpm to check on(xbill-2.0-16.i386.rpm for example)
2.Remove any xbill's on the system.
3.rpm ivh xbill-2.0.16.i386.rpm --excludepath=/usr --excludepath=/var
3.Check if /usr/lib/xbill exist and if /var/lib/games/xbill exists.
4.Check that only /etc/X11/applnk/Games/xbill.desktop exists.


 
    

Actual Results:  Problem - rpm excluded /var only

Expected Results:  only /etc/X11/applnk/Games/xbill.desktop exists.


Additional info:

Ilan Shufer - ilan@aduva.com

Comment 1 Jeff Johnson 2003-07-21 20:09:42 UTC
Your xbill test case "works" with (about to be built)
rpm-4.2.1-0.30. I know of no reason why the test case shouldn/t

Comment 2 Jeff Johnson 2003-07-21 20:11:09 UTC
... work with every version since rpm-4.1, but have not looked.

BTW -0.31, not -0.30.

Comment 3 Ilan Shufer 2003-07-22 14:06:13 UTC
Doesn't work on a clean RH9.
rpm-4.2-0.69.
popt-1.8-0.69.
This time , rpm doesn't even exclude one directory. All the files exist on the
system.


Comment 4 Jeff Johnson 2003-07-29 13:08:34 UTC
Yes, doesn't work on RH9.

Yes, fixed in -0.31

REOPENING is not your best avenue to fix. Try installing
-0.30.


Note You need to log in before you can comment on or make changes to this bug.