Bug 991677 - font colors are not saved when no background image is used
font colors are not saved when no background image is used
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-file-manager (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-03 10:30 EDT by Emmanuel Seyman
Modified: 2014-05-08 23:04 EDT (History)
5 users (show)

See Also:
Fixed In Version: mate-file-manager-1.6.4-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-02 17:01:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emmanuel Seyman 2013-08-03 10:30:42 EDT
A user I just met has mate installed with a black background and white fonts (to ease readability). When she logins to her system, the fonts are dark grey (the default?) and she is forced to choose a background image (the fonts become white) and then go back to the "solid color" option.

This problem doesn't happen when the background selected is an image.
Comment 1 Wolfgang Ulbrich 2013-08-03 14:28:46 EDT
I don't see the issue here, if i choose a black background and logout/login i see for 1 sec the darkgray fonts before it change to white fonts.
That's the normal behaviour.
Comment 2 Renée 2013-08-04 01:47:31 EDT
Hello. I am the user Emmanuel was referring to and can confirm that the dark grey font doesn't last for one second, it stays like that (illisible).
Comment 3 Wolfgang Ulbrich 2013-08-04 05:23:26 EDT
Which theme you use?
Comment 4 Wolfgang Ulbrich 2013-08-04 08:10:13 EDT
It seems we have a font rendering issue. Do a change in font configuration in mate-appearance-properties. This should fix the issue.
In general i suggest to change 'hinting' to 'slight' to have a better look of the desktop.
In a terminal do
gsettings set org.mate.font-rendering hinting slight
Comment 6 Renée 2013-08-05 01:36:15 EDT
(In reply to Wolfgang Ulbrich from comment #3)
> Which theme you use?

"No Desktop Background", the first option. With colour selection being "Solid Colour" > black.
Comment 7 Renée 2013-08-05 01:48:03 EDT
(In reply to Wolfgang Ulbrich from comment #4)
> It seems we have a font rendering issue. Do a change in font configuration
> in mate-appearance-properties. This should fix the issue.
> In general i suggest to change 'hinting' to 'slight' to have a better look
> of the desktop.
> In a terminal do
> gsettings set org.mate.font-rendering hinting slight

Thanks. But I tried this and it didn't work.
Comment 8 Wolfgang Ulbrich 2013-08-05 06:24:03 EDT
(In reply to Renée from comment #6)
> (In reply to Wolfgang Ulbrich from comment #3)
> > Which theme you use?
> 
> "No Desktop Background", the first option. With colour selection being
> "Solid Colour" > black.

You didn't use a desktop theme, weird? Every linux deskttop use a desktop theme ;)
There is a different between background image and theme.
Comment 9 Renée 2013-08-07 11:59:06 EDT
(In reply to Wolfgang Ulbrich from comment #8)
> (In reply to Renée from comment #6)
> > (In reply to Wolfgang Ulbrich from comment #3)
> > > Which theme you use?
> > 
> > "No Desktop Background", the first option. With colour selection being
> > "Solid Colour" > black.
> 
> You didn't use a desktop theme, weird? Every linux deskttop use a desktop
> theme ;)
> There is a different between background image and theme.

Sorry, it says "custom" theme.
Comment 10 Wolfgang Ulbrich 2013-08-26 03:21:38 EDT
Here at mate forum a user found a workaround for the issue, simply using a backround image with single color.
http://forums.mate-desktop.org/viewtopic.php?f=2&t=1639
Comment 11 Emmanuel Seyman 2013-08-26 06:15:46 EDT
(In reply to Wolfgang Ulbrich from comment #10)
>
> Here at mate forum a user found a workaround for the issue, simply using a
> backround image with single color.

Yes, I forgot to mention that Renée and I came up with the same workabout. But it should really work without having to do this.
Comment 12 Heldwin 2013-10-09 02:13:38 EDT
I have this problem too, in f19 and f20.

I have also found this workaround, but a fix for this would help.
Comment 13 Wolfgang Ulbrich 2013-12-29 04:44:01 EST
(In reply to Heldwin from comment #12)
> I have this problem too, in f19 and f20.
> 
> I have also found this workaround, but a fix for this would help.
Ask directly at upstream for help.
https://github.com/mate-desktop/mate-file-manager/issues/105
Comment 14 Heldwin 2014-04-05 09:34:05 EDT
Not sure it comes from mate though.
Still looking for a way to solve this in f20.

Actually, doing a [CTRL] + r , does fix it pretty fast
If I move, not copy, a font in: /usr/share/fonts, it fixes it too.

So actually I am looking for the process watching /usr/share/fonts that refreshes the desktop and the font colors.

With this information, do we still need to ask upstream mate-desktop ?
Or would it be to ask in an other place ?
Comment 15 Wolfgang Ulbrich 2014-04-05 12:56:11 EDT
(In reply to Heldwin from comment #14)
> Not sure it comes from mate though.
> Still looking for a way to solve this in f20.
> 
> Actually, doing a [CTRL] + r , does fix it pretty fast
> If I move, not copy, a font in: /usr/share/fonts, it fixes it too.
> 
> So actually I am looking for the process watching /usr/share/fonts that
> refreshes the desktop and the font colors.
> 
> With this information, do we still need to ask upstream mate-desktop ?
Yes this is a good idea.
> Or would it be to ask in an other place ?

But currently i don't see the issue anymore in f20 if i choose a solid black background.
After a logout the font color is white.
But i use latest builds from mate-desktop and mate-file-manager from updates-testing.
https://admin.fedoraproject.org/updates/FEDORA-2014-4710/mate-desktop-1.6.2-2.fc20,mate-file-manager-1.6.4-2.fc20?_csrf_token=d3690559c2dbbcc77dc0f913eaa7c8912e432102

Note, both updates need to install together, otherwise caja won't start!!!!
I've revert the caja autostart delay because upstream has definitely fix the x-caja-windows issue.

Could you pls test those updates for confirming that the font color is white now after a logout?
Comment 16 Heldwin 2014-04-06 17:23:52 EDT
nope, it doesn't fix it for me :/

I tried these updates:
* mate-desktop-1.6.2-2.fc20.x86_64
* mate-desktop-libs-1.6.2-2.fc20.x86_64
* mate-file-manager-1.6.4-2.fc20.x86_64
* mate-file-manager-extensions-1.6.4-2.fc20.x86_64
* mate-file-manager-schemas-1.6.4-2.fc20.x86_64

To test if it was my installation, I tried :
* a default theme, with a solid black background.
* with an other test user.

But still the same.
Comment 17 Fedora Update System 2014-04-29 16:53:57 EDT
mate-file-manager-1.6.4-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mate-file-manager-1.6.4-4.fc20
Comment 18 Fedora Update System 2014-04-29 16:54:06 EDT
mate-file-manager-1.6.4-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-file-manager-1.6.4-4.fc19
Comment 19 Heldwin 2014-04-30 14:17:03 EDT
Yessss :)

The font color is fixed with these updates.
Thanks :)
Comment 20 Fedora Update System 2014-05-01 02:59:16 EDT
Package mate-file-manager-1.6.4-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mate-file-manager-1.6.4-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-5824/mate-file-manager-1.6.4-4.fc19
then log in and leave karma (feedback).
Comment 21 Fedora Update System 2014-05-02 17:01:07 EDT
mate-file-manager-1.6.4-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2014-05-08 23:04:29 EDT
mate-file-manager-1.6.4-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.