Bug 991703 - [abrt] java-1.7.0-openjdk-1.7.0.25-2.3.10.10.fc19: os::abort(bool): Process /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.10.10.fc19.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
[abrt] java-1.7.0-openjdk-1.7.0.25-2.3.10.10.fc19: os::abort(bool): Process /...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
abrt_hash:46776e689e88d84c6e72a31b810...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-03 16:42 EDT by Peter Mihaly Avramucz
Modified: 2013-08-12 12:23 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-12 12:23:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (68.97 KB, text/plain)
2013-08-03 16:42 EDT, Peter Mihaly Avramucz
no flags Details
File: cgroup (140 bytes, text/plain)
2013-08-03 16:42 EDT, Peter Mihaly Avramucz
no flags Details
File: core_backtrace (3.17 KB, text/plain)
2013-08-03 16:42 EDT, Peter Mihaly Avramucz
no flags Details
File: dso_list (13.82 KB, text/plain)
2013-08-03 16:42 EDT, Peter Mihaly Avramucz
no flags Details
File: environ (1.46 KB, text/plain)
2013-08-03 16:42 EDT, Peter Mihaly Avramucz
no flags Details
File: hs_err.log (128.49 KB, text/plain)
2013-08-03 16:43 EDT, Peter Mihaly Avramucz
no flags Details
File: limits (1.29 KB, text/plain)
2013-08-03 16:43 EDT, Peter Mihaly Avramucz
no flags Details
File: maps (94.72 KB, text/plain)
2013-08-03 16:43 EDT, Peter Mihaly Avramucz
no flags Details
File: open_fds (19.27 KB, text/plain)
2013-08-03 16:43 EDT, Peter Mihaly Avramucz
no flags Details
File: proc_pid_status (968 bytes, text/plain)
2013-08-03 16:43 EDT, Peter Mihaly Avramucz
no flags Details
File: var_log_messages (1.61 KB, text/plain)
2013-08-03 16:43 EDT, Peter Mihaly Avramucz
no flags Details

  None (edit)
Description Peter Mihaly Avramucz 2013-08-03 16:42:36 EDT
Description of problem:
I was developing with Eclipse Android SDK Version. Maybe a popup or an Android feature made Eclipse crash...
Please note that this happens with Oracle JDK 1.7.0_17 too.

Version-Release number of selected component:
java-1.7.0-openjdk-1.7.0.25-2.3.10.10.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 3
cmdline:        /usr/bin/java -Dosgi.requiredJavaVersion=1.6 -XX:MaxPermSize=512m -Xms40m -Xmx1024m -Declipse.buildId=v22.0.1-685705 -jar /home/muczy/progik/adt-bundle-linux-x86_64-20130522/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar -os linux -ws gtk -arch x86_64 -showsplash -launcher /home/muczy/progik/adt-bundle-linux-x86_64-20130522/eclipse/eclipse -name Eclipse --launcher.library /home/muczy/progik/adt-bundle-linux-x86_64-20130522/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.200.v20120913-144807/eclipse_1502.so -startup /home/muczy/progik/adt-bundle-linux-x86_64-20130522/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar --launcher.overrideVmargs -exitdata 1f28009 -product com.android.ide.eclipse.adt.package.product -vm /usr/bin/java -vmargs -Dosgi.requiredJavaVersion=1.6 -XX:MaxPermSize=512m -Xms40m -Xmx1024m -Declipse.buildId=v22.0.1-685705 -jar /home/muczy/progik/adt-bundle-linux-x86_64-20130522/eclipse//plugins/org.eclipse.equinox.launcher_1.3.0.v20120522-1813.jar
crash_function: os::abort(bool)
executable:     /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.10.10.fc19.x86_64/jre/bin/java
kernel:         3.10.3-300.fc19.x86_64
runlevel:       N 5
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 os::abort(bool) at /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.10.10.fc19.x86_64/jre/lib/amd64/server/libjvm.so
 #3 VMError::report_and_die() at /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.10.10.fc19.x86_64/jre/lib/amd64/server/libjvm.so
 #4 crash_handler(int, siginfo_t*, void*) at /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.10.10.fc19.x86_64/jre/lib/amd64/server/libjvm.so
 #6 __strlen_sse2_pminub at ../sysdeps/x86_64/multiarch/strlen-sse2-pminub.S:38
 #7 ElfFile::ElfFile(char const*) at /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.10.10.fc19.x86_64/jre/lib/amd64/server/libjvm.so
 #8 ElfDecoder::decode(unsigned char*, char*, int, int*, char const*) at /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.10.10.fc19.x86_64/jre/lib/amd64/server/libjvm.so
 #9 os::dll_address_to_function_name(unsigned char*, char*, int, int*) at /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.10.10.fc19.x86_64/jre/lib/amd64/server/libjvm.so
 #10 frame::print_on_error(outputStream*, char*, int, bool) const at /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.10.10.fc19.x86_64/jre/lib/amd64/server/libjvm.so
 #11 VMError::report(outputStream*) at /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.10.10.fc19.x86_64/jre/lib/amd64/server/libjvm.so
 #12 VMError::report_and_die() at /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25-2.3.10.10.fc19.x86_64/jre/lib/amd64/server/libjvm.so
Comment 1 Peter Mihaly Avramucz 2013-08-03 16:42:42 EDT
Created attachment 782380 [details]
File: backtrace
Comment 2 Peter Mihaly Avramucz 2013-08-03 16:42:46 EDT
Created attachment 782381 [details]
File: cgroup
Comment 3 Peter Mihaly Avramucz 2013-08-03 16:42:50 EDT
Created attachment 782382 [details]
File: core_backtrace
Comment 4 Peter Mihaly Avramucz 2013-08-03 16:42:54 EDT
Created attachment 782383 [details]
File: dso_list
Comment 5 Peter Mihaly Avramucz 2013-08-03 16:42:57 EDT
Created attachment 782384 [details]
File: environ
Comment 6 Peter Mihaly Avramucz 2013-08-03 16:43:03 EDT
Created attachment 782385 [details]
File: hs_err.log
Comment 7 Peter Mihaly Avramucz 2013-08-03 16:43:07 EDT
Created attachment 782386 [details]
File: limits
Comment 8 Peter Mihaly Avramucz 2013-08-03 16:43:13 EDT
Created attachment 782387 [details]
File: maps
Comment 9 Peter Mihaly Avramucz 2013-08-03 16:43:17 EDT
Created attachment 782388 [details]
File: open_fds
Comment 10 Peter Mihaly Avramucz 2013-08-03 16:43:21 EDT
Created attachment 782389 [details]
File: proc_pid_status
Comment 11 Peter Mihaly Avramucz 2013-08-03 16:43:25 EDT
Created attachment 782390 [details]
File: var_log_messages
Comment 12 Omair Majid 2013-08-05 17:24:39 EDT
Crash originated from Eclipse/swt. The maintainers of eclipse and swt may have a better idea about what's wrong.
Comment 13 Peter Mihaly Avramucz 2013-08-06 03:35:36 EDT
In the mean time I've found two workarounds:
1. add "-Dorg.eclipse.swt.browser.DefaultType=mozilla" to eclipse.ini, because something happens in webkit...
2. download a fresh Eclipse from eclipse.org (and then install android tools), because fresh Eclipse versions do not have this issue.

Since the Eclipse I was using was from Google/Android and not from Fedora you might close this bug with invalid if you like.
Comment 14 Alexander Kurtakov 2013-08-12 12:23:17 EDT
Peter, I would really recommend you using eclipse from fedora as it is compiled against the libraries we ship and fixes are applied as found and fixed. You should be able to install adt on top of it too if you like (just make sure to install the needed eclipse-wtp* packages too) .
Closing the bug as if someone else build it there is not much more we can do.

Note You need to log in before you can comment on or make changes to this bug.