Bug 991716 - virt-manger/kvm broken with 3.11.0-0.rc3.git3.2.fc20.x86_64 [on F19]
virt-manger/kvm broken with 3.11.0-0.rc3.git3.2.fc20.x86_64 [on F19]
Status: CLOSED DUPLICATE of bug 984134
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-03 21:07 EDT by Satish Balay
Modified: 2013-08-05 10:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 10:15:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log (64.30 KB, text/x-log)
2013-08-03 21:07 EDT, Satish Balay
no flags Details

  None (edit)
Description Satish Balay 2013-08-03 21:07:50 EDT
Created attachment 782402 [details]
dmesg log

Description of problem:

I'm unable to start my virtual machines [via virt-manager/kvm] on F19 with 3.11.0-0.rc kernels. The same VMs [win7, rawhide] boot fine with kernel-3.9.9-302.fc19.x86_64 and kernel-3.10.2-301.fc19.x86_64

Version-Release number of selected component (if applicable):
qemu-kvm-1.4.2-4.fc19.x86_64
virt-manager-0.10.0-1.fc19.noarch

And tried these rawhide-nodebug kernels
kernel-3.11.0-0.rc2.git3.2.fc20.x86_64
kernel-3.11.0-0.rc3.git2.2.fc20.x86_64
kernel-3.11.0-0.rc3.git3.2.fc20.x86_64

How reproducible:

Always

Steps to Reproduce:
1. F19 upgraded from F18
2. install rawhide-nodebug kernel
3. start virt-manager and attempt to run VMs

Actual results:

VMs do not start

Expected results:

VMs to start.

Additional info:

The hardware is Thinkpad T420s, with Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz

First issue: I noticed kvm, intel_kvm were not loaded by 3.11-rc krnels- but they are automatically loaded by 3.9/3.10 kernels.

[root@asterix ~]# lsmod |grep kvm
[root@asterix ~]#


Due to this - I get the following error from virt-manager
>>>>

Error starting domain: unsupported configuration: Domain requires KVM, but it is not available. Check that virtualization is enabled in the host BIOS, and host configuration is setup to load the kvm modules.

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 100, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 122, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1210, in startup
    self._backend.create()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 698, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: unsupported configuration: Domain requires KVM, but it is not available. Check that virtualization is enabled in the host BIOS, and host configuration is setup to load the kvm modules.

<<<<<<<

Next I try 'modprobe kvm_intel'

[root@asterix ~]# modprobe kvm_intel
[root@asterix ~]# lsmod |grep kvm
kvm_intel             138528  0 
kvm                   421021  1 kvm_intel
[root@asterix ~]#

But now I get the following errors - when I start my VMs [the first one from Win7-VM - the second one from  rawhide VM

>>>>>>>>>>>>
Error starting domain: internal error Cannot find suitable CPU model for given data

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 100, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 122, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1210, in startup
    self._backend.create()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 698, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: internal error Cannot find suitable CPU model for given data

++++++++++++

Error starting domain: unsupported configuration: hda-duplex not supported in this QEMU binary

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 100, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 122, in tmpcb
    callback(*args, **kwargs)
  File "/usr/share/virt-manager/virtManager/domain.py", line 1210, in startup
    self._backend.create()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 698, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: unsupported configuration: hda-duplex not supported in this QEMU binary
<<<<<<<<<<<<<

Perhaps I need qemu-kvm from rawhide? [in which case the primary issue would be " kvm_intel not autoloading"
Comment 1 Josh Boyer 2013-08-05 10:15:35 EDT

*** This bug has been marked as a duplicate of bug 984134 ***
Comment 2 Satish Balay 2013-08-05 10:51:28 EDT
Ah - didn't realise I had to restart libvirtd after loading kvm_intel. Now my VMs do boot up on F19.

Note You need to log in before you can comment on or make changes to this bug.