Bug 991743 - yum-cron UnicodeDecode error
yum-cron UnicodeDecode error
Status: CLOSED DUPLICATE of bug 992797
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-04 05:00 EDT by Till Maas
Modified: 2013-08-05 07:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 07:33:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2013-08-04 05:00:14 EDT
Description of problem:
yum-cron just shows a UnicodeDecode error.

Version-Release number of selected component (if applicable):
yum-cron-3.4.3-103.fc19


I got this by mail:
/etc/cron.daily/0yum-daily.cron:

Traceback (most recent call last):
  File "/usr/sbin/yum-cron", line 1123, in <module> 
    main()
  File "/usr/sbin/yum-cron", line 1120, in main
    base.updatesCheck()
  File "/usr/sbin/yum-cron", line 1026, in updatesCheck
    self.findDeps()
  File "/usr/sbin/yum-cron", line 928, in findDeps
    self.emitCheckFailed("Failed to build transaction: %s" %(str.join("\n", resmsg),))
  File "/usr/sbin/yum-cron", line 1085, in emitCheckFailed
    map(lambda x: x.checkFailed(error), self.emitters)
  File "/usr/sbin/yum-cron", line 1085, in <lambda>
    map(lambda x: x.checkFailed(error), self.emitters)
  File "/usr/sbin/yum-cron", line 109, in checkFailed
    self.sendMessages()
  File "/usr/sbin/yum-cron", line 689, in sendMessages
    print "".join(self.output)
UnicodeEncodeError: 'ascii' codec can't encode character u'\xf6' in position 120: ordinal not in range(128)
Comment 1 Zdeněk Pavlas 2013-08-05 07:33:38 EDT

*** This bug has been marked as a duplicate of bug 992797 ***

Note You need to log in before you can comment on or make changes to this bug.