Bug 99178 - MS IE 5.5 crashes after flagging a syntax error when a Bugzilla report is submitted.
MS IE 5.5 crashes after flagging a syntax error when a Bugzilla report is sub...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.2
i686 Linux
medium Severity high (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
http://bugzilla.redhat.com/bugzilla/e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-15 12:16 EDT by Mark Harig
Modified: 2013-06-23 23:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-07 02:11:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Harig 2003-07-15 12:16:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.18-27.7.x i686; en-US; 0.7)
Gecko/20010316

Description of problem:
MS Internet Explorer flags the following line in the function
"OpenEnterBugPage()" as having a syntax error:

>  owin.document.forms[0].submit();

Due to this error, IE 5.5 won't continue past the page on which it occurs.

Below is the text of this function:

/* Opens and prefills a Bugzilla Enter Bug page */
function OpenEnterBugPage() {
    CheckValues(document.BugInfoForm);
    if ( readyToFile ) {
        if ( URL ) {
            var owin = window.open( "", "_blank" );
            owin.document.writeln("<body>");
            owin.document.writeln("<form
action=\"https://bugzilla.redhat.com/bugzilla/enter_bug.cgi\"" +
                " method=get>");
            WriteHiddenToDoc(owin.document, "product", bug.Product);
            WriteHiddenToDoc(owin.document, "component", bug.Component);
            WriteHiddenToDoc(owin.document, "rep_platform", bug.Platform);
            WriteHiddenToDoc(owin.document, "version", bug.Version);
            WriteHiddenToDoc(owin.document, "priority", bug.Priority);
            WriteHiddenToDoc(owin.document, "bug_severity", bug.Severity);
            WriteHiddenToDoc(owin.document, "bug_file_loc", bug.URL);
            WriteHiddenToDoc(owin.document, "short_desc", bug.Summary);
            WriteHiddenToDoc(owin.document, "comment", long_desc);
            owin.document.writeln("</form>");
            owin.document.writeln("</body>");
            owin.document.close();
            owin.document.forms[0].submit();
        }
    }
    return;
}



Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.Attempt to enter a Bugzilla report at the URL listed above, using MS IE 5.5.
2.Click on the button "Open Bugzilla Entry Form".


Actual Results:  IE 5.5 displays a message

Additional info: The text of the Description field on the "easy_enter_bug.cgi"
web page appears to be significant in triggering this bug.  If the description
text is short, then the bug is NOT triggered.  I found that including the text
of the function, above, would trigger the bug/syntax error repeatedly.
Comment 1 David Lawrence 2006-04-08 13:46:11 EDT
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.
Comment 2 Mark Harig 2006-04-10 11:43:15 EDT
I am no longer able to reproduce this defect.  This may be because the problem
has been fixed in the newer version of Bugzilla or it may be because I no longer
have access to IE 5.5.  The problem does not occur on IE 6.
Comment 3 David Lawrence 2008-09-16 12:49:59 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 4 Noura El hawary 2008-11-07 02:11:48 EST
As reported by Mark while back he can not reproduce this error anymore. so the issue is considered fixed.

Noura

Note You need to log in before you can comment on or make changes to this bug.