Bug 991811 - libguestfs-1.23.12-2.fc20 fails to build due to tests: could not load kernel: invalid argument
libguestfs-1.23.12-2.fc20 fails to build due to tests: could not load kernel:...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-04 11:33 EDT by Petr Pisar
Modified: 2013-09-02 10:40 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-02 10:40:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2013-08-04 11:33:12 EDT
libguestfs-1.23.12-2.fc20 does not build due to failing tests in rawhide:

libguestfs: [00997ms] launch libvirt guest
*stdin*:4: libguestfs: error: could not create appliance through libvirt: internal error: process exited while connecting to monitor: qemu: could not load kernel '/builddir/build/BUILD/libguestfs-1.23.12/tmp/.guestfs-500/kernel.7293': Invalid argument
 [code=1 domain=10]
libguestfs: clear_socket_create_context: setsockcreatecon failed: NULL: Invalid argument [you can ignore this UNLESS using SELinux + sVirt]
libguestfs: trace: launch = -1 (error)
libguestfs: trace: close
libguestfs: closing guestfs handle 0x7f5c06c8d740 (state 0)
libguestfs: command: run: rm
libguestfs: command: run: \ -rf /builddir/build/BUILD/libguestfs-1.23.12/tmp/libguestfsTV4VlW
/builddir/build/BUILD/libguestfs-1.23.12/run: command failed with exit code 1
FAIL: qemu-snapshot-isolation.sh
Comment 1 Cole Robinson 2013-08-30 18:07:34 EDT
Rich, have you seen this before?
Comment 2 Richard W.M. Jones 2013-08-31 02:31:36 EDT
No idea.  How are you building this?  Koji?  Mock?  rpmbuild?
Are you setting any environment variables?  Note also the latest
version of libguestfs is 1.23.19-1.fc21 in Rawhide and
1.23.18-2.fc20 in the f20 branch, so you should test the latest
version in case there are miscellaneous fixes.
Comment 3 Petr Pisar 2013-09-02 03:18:40 EDT
Ah, sorry, I linked wrong build log in the URL field. This was a standard build in the Koji. A latest rawhide sources at those time.

Maybe current sources (libguestfs-1.23.20-2.fc21) are better, but they do not build either.

This was a FTBFS report from my Perl 5.18 mass rebuild. If you think it's not relevant anymore, feel free to close it.
Comment 4 Richard W.M. Jones 2013-09-02 10:40:41 EDT
1.23.20-2 didn't build because of broken fontconfig (bug 1003495,
now fixed).

1.23.20-3 should build -- it's building in Koji right now.

If you find errors in future please make sure:

(1) It's filed under the right component.  I didn't see this
bug at all because the component was set to libvirt.

(2) Include /link to the complete, unedited build logs.

Closing with resolution "RAWHIDE" because we think this
and other bugs should be fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.